2

I've set in lightdm.conf these 2 settings (under the Seat:* section) and the autologin doesn't work. It still ask me for user and password

autologin-user=user
autologin-user-timeout=0

I've tried with this setting in addition, but it still doesn't work

user-session=default

In addition, the checkbox "Don't ask for password on login" is disabled and not checked.

3

The section is probably wrong/missing. Create /usr/share/lightdm/lightdm.conf.d/02_user.conf with the following content:

[SeatDefaults]
autologin-user=<user>
autologin-user-timeout=0
  • This worked very well., and it is better to create a file named 01_debian.conf if there are none other there. Remember though, that setting autologin for guest will not work if autologin for user is set. local user donald trumps guest :-) – netfed Mar 7 at 16:24
0

My last answer worked only one time. I had to edit /usr/share/lightdm/lightdm.conf.d/01_debian.conf

[Seat:*]
greeter-session=lightdm-greeter
greeter-hide-users=false
autologin-session=true
#autologin-user=username
autologin-user-timeout=1
session-wrapper=/etc/X11/Xsession

(If greeter-hide-users=true I ever had to type my username. )

And Also in /etc/lightdm/lightdm.conf

greeter-session=lightdm-gtk-greeter
autologin-user= username
-1

Find a solution which works for me. Adding this setting in lightdm.conf :

greeter-session=lightdm-xsession

The value name is from

ls /usr/share/xgreeters/*.desktop

Pick the one you use.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.