0

I know that there are a lot of X11 forwarding questions out there, but they never seem to address a Windows client to Windows server setup, so I am beginning to question if it is even possible.

I have spent a long while trying to get X11 forwarding working when connecting to a Windows 7 server with OpenSSH installed from a Windows 10 client using Putty. My first step was to install OpenSSH on my Windows 7 server and connect to it from my Windows 10 client using Putty. All of this happened with no issues. Now the goal was to get GUI programs launched on my server to show up on my client. My steps have been:

  1. Install and run Xming on my client.
  2. Edit OpenSSH-install-location\sshd_config_default on my server and add:

    X11Forwarding yes X11DisplayOffset 10 X11UseLocalHost no

  3. Restart OpenSSH on my server

  4. Connect to server with Putty, ensuring that Connection > SSH > X11 > Enable X11 forwarding is checked. I've also tried X display location: localhost:0 and setting the DISPLAY env variable to 127.0.0.1:0 as suggested on many forums.
  5. Once connected, type 'notepad' to bring up my notepad application. Notepad does not come up on my client. Nothing happens on my client, but I can verify that the notepad process is running on my server.

The client side of things seems so simple that I believe that there is a problem on the server. All of the walkthroughs have you go to /etc/ssh/ and edit a config_default file. I'm on a windows machine, so this does not exist, but I figure the equivilant must be OpenSSH install location\sshd_config_default.

Some concerning things to note are that Xming says 'There are currently 0 clients connected' after I type notepad and the sshd_config_default had nothing about X11 already defined in it. I had to add everything, which leads me to believe that maybe this Windows OpenSSH does not support X11 forwarding?

Is Windows -> Windows SSH with X11 forwarding possible? If so, do I need a Windows SSH server that can support it, or is there another issue here?

Thanks!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.