4

My external HDD suddenly started reporting as "931.51 GB RAW (Primary)" in Windows disk management.

I tried using DiskInternals Partition Recovery, which indeed reported the drive being only seen as RAW, easily found a partition at sector 2048, spanning the full size of the disk, detected an NTFS system on it... and then it completely failed to find any files.

DISKPART sees the partition as RAW.

ChkDsk H:, however, DOES detect it as NTFS and checks the filesystem (finding indexing errors in file descriptor 5, which is root folder ".", so thus far I only ran it in read-only mode out of caution).

MiniTool, another recovery program, immediately noticed the disk, with a correct volume label and explorable contents, even without running a recovery pass, but the free version doesn't let me copy files.

Finally, TestDisk is able to read the disk's contents without any problems, without running a specialized recovery pass - it accesses the NTFS system as if everything was fine.

Reading the disk in hex mode, I see the MBR area is completely empty (all zeroes) except for a serial number and one, seemingly correct, partition entry:

0000000000: 00 00 00 00 00 00 00 00 | 00 00 00 00 00 00 00 00
....
00000001A0: 00 00 00 00 00 00 00 00 | 00 00 00 00 00 00 00 00
00000001B0: 00 00 00 00 00 00 00 00 │ 39 72 8E 13 00 00 00 20  <- serial, part.type
00000001C0: 21 00 07 FE FF FF 00 08 │ 00 00 AC 65 70 74 00 00  <- partition 1
00000001D0: 00 00 00 00 00 00 00 00 │ 00 00 00 00 00 00 00 00
00000001E0: 00 00 00 00 00 00 00 00 │ 00 00 00 00 00 00 00 00
00000001F0: 00 00 00 00 00 00 00 00 │ 00 00 00 00 00 00 55 AA  <- magic
....
00000FFFF0: 00 00 00 00 00 00 00 00 │ 00 00 00 00 00 00 00 00
0000100000: EB 52 90 4E 54 46 53 20 │ 20 20 20 00 02 08 00 00  <- NTFS     

The partition is of type 07, so it's NTFS, starts at sector 2048, and actually the filesystem is still there - at offset 0x100000 (2048*512 sector size) a nice NTFS system starts. So it seems all to be there.

From the looks of it, I'd expect Windows to see the disk as an NTFS partition and maybe require a filesystem check - not see it as not formatted at all.

Does that mean that the disk is readable and fine, but somehow Windows can't access it? Or did Windows cache the MBR (as I have not rebooted the machine yet)? Or maybe I don't even need an MBR, since this is not a bootable drive, merely an external USB storage unit?

What should I do to make Windows recognize the NTFS partition, if it's all there, intact and apparently healthy enough to be read without sector-by-sector recovery passes? Should I let chkdsk H: /f run and maybe try to fix it? (I haven't tried yet, as I heard chkdsk destroys data in some fringe cases)

(This is not a generic "how do I recover my data?" question, recovery wasn't that big of an issue in this case, as there was no unique data on that disk - it's more of a "what's missing, why doesn't it work, can it be fixed instead of recovered?" question. Most "RAW partition" trouble reports involve CHKDSK refusing to operate on a RAW partition; here, CHKDSK works fine, oddly enough.)

  • Errors in the root entry are anything but "fine". First of all, please try Testdisk and tell us if it lists your files. Do not run chkdsk yet! Then we will see what should be done. – Andrea Lazzarotto Mar 31 '18 at 10:00
  • TestDisk, in Filesystem Tools mode, is able to extract files just fine, and I'm backing stuff up right now, thanks a lot! However, I'd still like to try to "fix" it, if possible, even if just to see if it can be done. It makes me awfully curious how Chkdsk or TestDisk is able to read the filesystem without any issues or "advanced recovery", while Windows itself sees the partition as RAW. – Sinus Mackowaty Mar 31 '18 at 14:05
  • You might want to add that last bit of info to your question. I can then answer about Chkdsk vs Testdisk for instance. – Andrea Lazzarotto Mar 31 '18 at 15:11
  • I edited the question to be a more "what happened, why doesn't it work" instead of a "how do I recover the data" cry for help. – Sinus Mackowaty Mar 31 '18 at 21:17
  • OK short version since the Q is closed now, Chkdsk does not look at the partition table but it looks at the MFT entries directly. So does Testdisk which mainly searches for partition boot sectors (the first and the last in case of a NTFS file system). For a more detailed discussion, see Section 1.3 of my MSc thesis. – Andrea Lazzarotto Apr 1 '18 at 15:53
1

In the end, after I used TestDisk to copy all the important files off the disk, I finally risked running chkdsk /f and it didn't detect any problems, but apparently removed the "requires checking" flag set after a careless disconnection, and so afterwards the disk was perfectly fine.

I felt a bit silly afterwards, having gone all PhD on the disk, when all it needed was a routine check, but maybe the disk-salvage tools should be able to recognize the "requires checking" flag...

0

In your case, I would recommend to you use initialization of the disk. Open Disk management as you deed already. click on the disk and select initialize diskhow to initialize disk in w10 Not sure about other recommended software, but this Diskinternals partition recovery tool https://www.diskinternals.com/partition-recovery/solution-for-raw-partition-recovery/ is what you will need to rebuild file system and data restore (I have no idea if I am allowed to put a link here, I usually read - not answer). Good luck!

  • 1
    Is this a case of “We had to destroy the village in order to save it” or “The medical treatment was a success, and we cured the disease; however, the patient died”?    Disk initialization sounds like a nuclear option, not a search and rescue operation. – Scott Mar 28 at 13:50
-1

When Windows is unable to read or mistakenly read any of these 3 places, Partition Table, Partition Boot Sector, and File System, it will report the corresponding partition as RAW. If it is due to partition table issue, you need to repair partition table. If it is due to file system error, you need to fix file system. If it is caused by boot sector issue, you need to fix boot sector. I got most information from this post: https://www.minitool.com/partition-disk/fix-raw-sd-card.html. Mabybe this post explains what you want to know.

  • 3
    -1. Link-only answers are low quality. Please edit your answer and make it self-contained, cite the crucial parts of the linked article here. And make sure it does answer the question (as opposed to maybe). – Kamil Maciorowski Apr 24 '18 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.