3

In Firefox version 59.0.2 on a Core i7 6xxx series with the latest nVidia graphics card drivers, when on battery power only, my two-finger touchpad scrolling experience in Firefox is terrible. When I scroll with two fingers and hold (i.e. not flick), scrolling by half a screen up or down, the scroll starts right away, but takes several seconds to get there. Here's an example. In this Gfy, I gestured fast and cleanly, in a split second, but it took several seconds to be done scrolling. The two finger gesture was in one motion, but the scrolling window seemed to scroll slow and medium speed and then slow again.

enter image description here

The problem isn't so much lag per se--it starts scrolling immediately; nor is it starving for CPU or resources. It seems instead that there is something programmatic keeping it from scrolling faster or "with more FPS".

Other Windows apps seem to scroll with the gesture just fine.

How can I fix Firefox's slow-responding two-finger touchpad scroll when not plugged in to AC power?

An internet search reveals a ton of dart-throwing ideas to fix similar (but not exact issues) I tried turning off smooth scrolling and pixel scrolling in about:config; that didn't help. I'm sure that the CPU behavior is different under battery power, but I don't see a setting "make touchpad scroll slow in Firefox" in Windows Power Options. Any ideas?

  • is Firefox using HW acceleration or not? Check this in about:support – magicandre1981 Mar 31 '18 at 14:25
  • I see lots of info in about:support. What setting am I looking for? – Patrick Szalapski Mar 31 '18 at 15:06
  • do the opposite of this: winaero.com/blog/disable-hardware-acceleration-firefox-quantum in the suport window you should also see if it works. I use german firefox so the names are different. – magicandre1981 Apr 1 '18 at 18:39
  • 3
    Try: (1) In Advanced settings for your power plan adjust "Minimum CPU power" on battery higher. Start with bumping it from 5% to 50% and then reduce if it helps. Might need reboot. (2) In about:config change mousewheel.min_line_scroll_amount higher. Start with bumping it from 5 to 50. Might need to restart Firefox. (3) What make is your touchpad and are you using the latest driver from the manufacturer? – harrymc Apr 9 '18 at 6:26
  • 1
    Try the Firefox Safe Mode to see if the cause is an add-on. – harrymc Apr 11 '18 at 6:46
2
+50

If the problem is only present in Firefox, then the first check is to try the Firefox Safe Mode, where all add-ons are disabled, as well as some other settings.

If the problem disappears in Safe Mode, the next step is to return to normal mode and disable the add-ons in bunches until a problematic add-on is isolated.

If that does not help, even when all the add-ons are disabled, then the problem is with some setting.

For the poster, the problematic setting was Hardware Acceleration, and the problem disappeared once it was disabled.

See the article Hardware acceleration and WindowBlinds causes Firefox to crash for instructions on disabling hardware acceleration.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.