1

Since upgrading my whole PC I am unable to run VMs in Binary Translation mode.

VT-x / Intel Virtualisation Technology is enabled in the BIOS however I require Binary Translation for use in Windows 95. Using VT-x works fine for the rest of my guests. The virtualization mode in the VM is set to binary translation, however I get the error below.

Is there another setting I need to set? Windows, VMWare, BIOS or VMX?


  • VMWare Version: 12.5.9 build-7535481

  • Windows Version: Windows 10, 64-bit (Build 15063) 10.0.15063

  • CPU: Intel i9 7900X (Skylake-X)

  • Motherboard: Asus TUF X299 Mark 2


Error when VM mode set to Binary Translation:

VMware Workstation unrecoverable error: (vcpu-0)

vcpu-0:VERIFY vmcore/vmm/main/cpuid.c:386 bugNr=1036521

I have read that people with AMD Ryzen CPUs have the same issue.

1

Is there another setting I need to set?

Yes, in the VM settings:

To configure processor settings for a selected virtual machine, select VM > Settings, click the Hardware tab, and select Processors.

Select the preferred execution mode for the virtualization engine. You usually do not need to change virtualization engine settings.

Automatic

Workstation Pro chooses the execution mode based on the guest operating system and the host CPU.

Binary translation

Workstation Pro uses a mix of directly executing guest code and binary translation to run the guest operating system. Guest memory mapping is performed by using shadow page tables.

Intel VT-x or AMD-V

Workstation Pro uses hardware extensions to run and isolate guest code. Guest memory mapping is performed by using shadow page tables.

Intel VT-x/EPT or AMD-V/RVI

Workstation Pro uses hardware extensions to run and isolate guest code. Guest memory mapping is performed by using hardware paging.

Source Configuring Virtual Machine Processor Settings

| improve this answer | |
  • Thanks for the reply. I already have Binary translation set in the VM options, but it shows the error above. I will update the question. Apologies for not being totally clear. – mt025 Apr 3 '18 at 13:30
0

I'm pretty sure that newer CPUs (Ryzen and Skylake-X) no longer support Binary Translation.

I installed VMWare worksation 14 and this option is no longer there. I also tried to rollback 12, but the same issue is still there.

Regardless, Workstation 14 solves the problem.

| improve this answer | |
  • Binary translation is no longer supported in Workstation 14. While maybe-ish 12 just had some incompatibility with those quite newer CPUs (indeed, Skylake and Ryzen are mentioned almost in the opening of the 14's release notes). – mirh Jan 21 at 23:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.