2

I have been using TortoiseSVN successfully for a while, but am now unable to checkout code!

It appears that all folders on my computer are being treated as 'versioned' by TortoiseSVN, with the same context menu I would expect for a folder that has a .svn subfolder.

I have created a brand new folder, and the right-click menu (both on or once inside that folder) contains "SVN Commit","SVN Update", etc, but no check out. If I try to actually use any of these available commands, I get the error

sqlite[S1]: no such table: wcroot

presumably because there is no repository here!

So far I have tried toggling the "Hide Menus for unversioned paths" option, rebooting, and uninstalling/reinstalling.

Anyone have a fix or some next steps?

| improve this question | | | | |
  • keep going up the directory tree until you find the erroneous .svn directory. – Mokubai Apr 3 '18 at 18:34
2

Based on Mokubai's comment, I found a C:\.svn folder! I tried 'show log' and a couple others on the C drive itself, but the same errors came up as from any other unversioned folder.

Now that I've deleted that .svn folder, I've regained my ability to check out.

I'm struggling to imagine how an erroneous .svn got added to the top-level C drive, especially since it had no information in it, but I guess this is solved.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.