I've been using Arch Linux for a while and bluetooth has been working without issues. Now, for no explicable reason, Arch doesn't detect my bluetooth adapters anymore.

I tried doing:
$ sudo systemctl enable bluetooth,
$ sudo systemctl start bluetooth and
$ sudo systemctl start dbus.

I've enabled generic bluetooth drivers:
$ sudo modprobe btusb.

I've installed: bluez, bluez-utils-compat and blueman.

$ sudo lsmod | grep bluetooth returns:

bluetooth             634880  11 btrtl,btintel,bnep,btbcm,btusb
ecdh_generic           24576  1 bluetooth
rfkill                 28672  7 bluetooth,acer_wmi,cfg80211
crc16                  16384  2 bluetooth,ext4

$ sudo lspci | grep blue returns nothing.

$ sudo hciconfig returns nothing.

$ sudo hcitool dev returns:


$ sudo dmesg | grep Blue returns:

[  283.807549] Bluetooth: Core ver 2.22
[  283.807585] Bluetooth: HCI device and connection manager initialized
[  283.807588] Bluetooth: HCI socket layer initialized
[  283.807589] Bluetooth: L2CAP socket layer initialized
[  283.807594] Bluetooth: SCO socket layer initialized
[  349.781130] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[  349.781135] Bluetooth: BNEP filters: protocol multicast
[  349.781148] Bluetooth: BNEP socket layer initialized

$ sudo rfkill list returns:

0: acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: acer-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

I've done:

$ bluetoothctl
[bluetoothctl]# scan on
No default controller available

When I open blueman-adapters, it opens but the window doesn't have any contents:

Blueman-adapters window

And when I open blueman-manager, the only functioning buttons are the View and Help menus:

Blueman-manager window

Some important info (if needed):

Model:           Acer Aspire S13 S5-371
Network Card:    Qualcomm Atheros QCA61x4A
uname -r:        4.15.14-1-ARCH
BIOS Ver:        v1.5
OSes:            Windows 10, Arch Linux (dual boot using rEFInd)
Built in Bluetooth 4.0 support
  • What does list return in bluetoothctl?
    – Hanlon
    Commented Apr 4, 2018 at 17:12
  • 1
    bluetoothctl list does not return anything
    – user891127
    Commented Apr 4, 2018 at 18:30
  • 5
    Have you managed to make it work? I have exactly the same problem on Ubuntu 18.04 (Dell XPS 15 9570) Commented Nov 15, 2018 at 13:33
  • I have the exactly same problem, but on Fedora 39. I suppose a reboot will help, but I really would like not doing that whenever the issue arises.
    – Person
    Commented Apr 5 at 20:39

6 Answers 6


Same symptoms as in the question happend to me on a Dell XPS 13 after installing Wacom software for a Intuos BT S tablet.

Solution for me was disabling Bluetooth in the BIOS, rebooting and enabling it in the BIOS again, as is said in this thread: https://ubuntuforums.org/showthread.php?t=2348005

  • It would be more helpful to post the relevant content from the link. The link would be useful if that site died.
    – Worthwelle
    Commented Jun 20, 2019 at 18:59
  • Worked for me, thank you so much. Had to use 'systemctl reboot --firmware-setup' to restart in bios since fastboot was enabled.
    – LVDV
    Commented Nov 3, 2019 at 15:58
  • This worked perfectly, if you don't even have bluetooth kernel modules installed and bluetooth was working before, just restart bluetooth in BIOS, no need to setup bluetooth by hand.
    – jcubic
    Commented Apr 21, 2020 at 7:15
  • 2
    This worked for me on laptop Dell Inspiron 5570 (5000 series). However, for me even rfkill list listed only wifi.
    – andrybak
    Commented Apr 23, 2020 at 20:05
  • This worked for me on my desktop with Asrock X570 Taichi motherboard
    – Oenotria
    Commented Apr 28, 2020 at 16:03

Are you dual-booting windows? If you are, make sure to disable FastBoot in Windows. This is from Intel Documentation:

About dual-boot with Windows and "fast-boot" enabled If you have a dual-boot machine with a recent version of Windows and start seeing problems during initialization of the WiFi device when booting Linux, the problem could be due to the “fast startup” feature on Windows.

With this feature enabled, Windows don't really shut down the entire system, but leaves things partially running so you can start the machine faster again. Try to disable this option, on Windows 10 it should be in “Control Panel→Hardware and Sound→Power Options→System Settings”, then disable the “Fast Startup” option in “Shutdown Settings”. This will cause Windows to fully shutdown and may solve the issue.


Had a similar issue and figured out this was the reason.

  • This fixed this issue for me. (And may have also been a source of some other duel-boot issues.) Thanks.
    – SO Stinks
    Commented May 27, 2021 at 4:26

No need to speculate as I've already solved this issue.

I went into Windows and found out that bluetooth didn't work there either (there was no slider to turn bluetooth on or off).

However, I figured out that if I opened the action menu (WIN-KEY+A) then clicked on the bluetooth icon twice (which was blue and had my phone's name on it, weird), bluetooth started working again somehow. I went back to Linux and it was working there as well. Problem solved it seems.

  • 20
    This does not solve the issue really. One should be able to employ Linux to do whatever it is needed in Linux. I don't have Windows and I'm not planning to have and so... your answer does not really help me at all. Commented May 18, 2018 at 20:08
  • 1
    what "action menu"?? what "phone name"??
    – haelix
    Commented Sep 8, 2018 at 21:23
  • 1
    Annoyingly this helped me. I jsut rebooted to windows once. And the it started working again...
    – janw
    Commented Nov 22, 2018 at 8:49
  • Having a Debian/Win7 configuration, this was the solution to my problem. I went into Windows and kicked all connected devices from bluetooth. Went into debian again and voila
    – Narase
    Commented Dec 27, 2019 at 17:12
  • I'm probably facing the same problem, but I'm on Debian and installing Windows is not an option. If I find a way to enable the device from Linux I'll post it here.
    – David
    Commented Mar 23, 2020 at 10:46

Whilst this is not an answer, I provide it here in the hope that it could be useful for people landing in this thread. Here you go:

I had troubles with my Philips SHB9850NC and I resolved the issue by installing pulseaudio-module-bluetooth. Later I've installed blueman too, which is a Gnome thing. Since I use KDE, I've removed blueman after that. Then troubles started to happen: my Bluetooth adapter vanished from existence.

The procedure below is intended to reinstall the entire Bluetooth stack for KDE, including pulseaudio-module-bluetooth. However, this didn't solve the issue. My Bluetooth adapter is still not detected.

$ sudo apt install --reinstall -y bluetooth bluez bluez-firmware bluez-hcidump bluez-cups bluez-tools pulseaudio-module-bluetooth
$ for cmd in unload load ;do sudo pactl ${cmd}-module module-bluetooth-discover ;done
$ for cmd in force-reload restart ;do sudo service bluetooth ${cmd} ;done
  • I've tried a myriad of things and one them was this. However Bluetooth re-worked after doing this + restarting. It was one of a bunch of steps, so I can't be sure if this solved it. Thanks anyways.
    – petobens
    Commented Apr 29, 2019 at 23:08

I spent a long time looking for an arch specific solution to this problem but booting into a live USB and seeing no bluetooth devices found there either convinced me it was a hardware issue.

Perhaps this is ASUS specific but I found this SO answer referencing a Reddit Post saying to:

  1. Shutdown the machine
  2. Remove the power cable
  3. Hold power button for 30s (I believe this is to clear all capacitors)
  4. Put power cable back in and start machine

This worked for me.

  • Worked for me too! The bluetooth hardware was not showing under Ubuntu nor Windows, and now it works.
    – merlinND
    Commented Jan 28 at 14:07

I use manjaro, but bluetooth dongle was not working.

It did the following steps to fix it.

  • removed package: manjaro-firmware

  • and installed bcm43142a0-firmware

    I installed the bluetooth on another laptop on windows 10 and it worked. I don't know if this step helped. You never know.

  • Install kernel linux 5.9.1 rt19-1 real-time

  • Installed realtek bluetooth firmware for RTL 8761B based devices (rtl8761b-fw)

Realtek Bluetooth 5.0+EDR by techkey is working pretty good so far.

  • Kernel: 5.9.1-1-rt19-MANJARO x86_64
  • bits: 64
  • Desktop: KDE Plasma 5.20.4
  • Distro: Manjaro Linux

You must log in to answer this question.