0

I'm trying to live-stream my full screen application and to view it from another machine in the same network.

I'm using this command to start the streaming, it works well and I can see the livestream with 2/3 seconds of delay:

ffmpeg -video_size 1920x1080 -r 10 -f x11grab -i :0.0 -f mpegts -b:v 4096k udp://othermachineaddress:8554

But when I try to play the video sometimes I can see some graphics artifacts with the desktop background (some portion of it) of the streaming machine (which has my application in full screen modality, you can't see the desktop background on the real machine).

I suppose that is not a problem related with the UDP stream but with screen capture (there is no other graphic artifact like green screen that suggests packet loss). During the streaming the CPU and the RAM load is minimal.

I'm using Ubuntu 16.04 on both machines.

There are some flags that I can try to resolve the "Desktop background artifact"?

  • Note: Please post your edits into an answer; that way it's much more visible the solution for the problem – CaldeiraG Apr 6 '18 at 15:15
0

This problem seems to be caused by Cinnamon on the streaming machine. Same problem here

Two possible solutions, both works for me:

  1. Change the DE. I tried both Gnome3 and Unity, streaming works fine.
  2. Disable from Nvidia Settings "Allow Flipping" option. It allows me to fix the problem with Cinnamon. Example
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.