I have a bit of a strange issue with my 'Backup and Sync' Google Drive. Specifically only 1 file in a particular folder I have selected to sync is not syncing to my device and I cant figure out why. More details below.

I have configured my Google Drive as follows:

Drive Config

However if I view the following file path


On the web portal for Google Drive the following appears...

Excel File on Google Drive

But when I view it on my local computer the excel file shown is nowhere to be seen!

Excel File not on Device

I have tried the following to fix the issue:

  • Ensure Google Drive has finished syncing
  • Uninstall and re-install Google Drive (twice!)

Does anyone on here have any ideas why this file is not syncing??

  • Did you set up a filter somewhere, that would prevent Google Drive to download .xlsm files? – piko Apr 6 '18 at 8:20
  • You can setup filters? – Josh Apr 7 '18 at 9:28
  • I'm not sure, as I don't use Google Drive myself, but this is a feature that exists on some other cloud services. I thought this file type might be unchecked for some reason. – piko Apr 7 '18 at 11:52
  • @piko I just checked and excluding file types is not supported by Google Drive. quora.com/… Any other ideas? – Josh Apr 9 '18 at 0:47

Google's advice specifically for their failure to sync Excel files is to not use Excel. That's right, this terrible technical problem can only be solved by using Google Sheets, according to Google. No explanation as to why, out of all file types, specifically Excel files can't be sync'd.


So there's the official answer: Use Google Sheets. I sympathize if you suspect there is more than technical difficulties involved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.