I tried to remove two files from the system and then put them back. However since I put them back my Superdrive is not working. Files are

IOCDStorageFamily.kext and IODVDStorageFamily.kext

My assumption is that the problem is the xattr.

When I try to run the following command and add an xattr like the other files around:

sudo xattr -wx com.apple.rootless "`cat ~/Desktop/attribute`" IOCDStorageFamily.kext

I am getting:

xattr: [Errno 1] Operation not permitted: 'IOCDStorageFamily.kext'

Everybody says it is the SIP, but I have disabled SIP csrutil status:

System Integrity Protection status: disabled.

When I run ls -lO we see two files that I care about

drwxr-xr-x  3 mh    wheel  -          102 Dec 19 21:07 IOCDStorageFamily.kext
drwxr-xr-x  3 root  wheel  restricted 102 Dec 19 21:11 IODVDStorageFamily.kext
drwxr-xr-x@ 3 root  wheel  restricted 102 Jul 16  2017 IOFireWireAVC.kext

File 1: I tried to make it with my user. no help. also I tried to remove "restricted" but that also didn't work.

File 2: Remained intact. Still can't edit xattr

File 3: Another file that is okay in its original form.

Help would be appreciated

(iMac 20" Early 2008, High Sierra)

2 Answers 2


I had a similar problem on MacOS 13.5.2 Ventura. The problem was that my terminal app (iTerm2) didn't have full disk access.

To fix it, go to System Settings → Privacy & Security → Full Disk Access. Enable the checkbox for your terminal app. It will restart the terminal, after which you will be able to successfully run xattr on the files you want.


I had a similar xattr problem. It turned out that the file was locked. Even though I was owner and had read/write privileges, while the file was locked I only had read privileges. I right clicked the file (in finder)>clicked the lock icon at the bottom so I could make changes>opened the "general" section>and clicked the "Locked" button to unlock it. Or if you prefer terminal you can try this: SetFile -a l file.ext. ref: Command to unlock "Locked" files on OS X and if that doesn't work for you then ref: Mac OS X locked files on Sierra cannot be unlocked by clearing immutable bit on command line

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .