1

I seem to be having an issue when it comes to mapping a network drive to Windows' Explorer. I am trying to map my NAS which is located in 'Router1', and my computer which is in 'Router2', but every time I attempt to map it I get the error Windows cannot access \\192.168.1.100\myshare. Subnet Configuration

In my case the scenario goes like this:

  • Router 1:
  • WAN: Static IP
  • LAN: 192.168.0.1/24
  • Router 2:
  • WAN: 192.168.1.32
  • LAN: 192.168.1.1/24

It also seems that both networks share the same SUBNET MASK

  • TP-Link Archer C9 – Matthew Correa Apr 7 '18 at 15:18
  • @PimpJuiceIT I tried your first solution, and it didn't work - I got the error Error code: 4003 Subnet Mask doesn't match the Destination Network address, please enter again. I've also updated the question with some extra info in case that helps. – Matthew Correa Apr 7 '18 at 15:53
  • 1
    You know what, you probably simply need to setup the static routing or whatever on the Router1 and tell it to send traffic on the other subnet over to Router2 WAN IP address of 192.168.0.32 and not do anything at all with Router2 static routing now that I think about it more. Otherwise when Router1 tries to get to the subnet not in it's LAN scope it will send that back out its WAN to the Internet rather than Router2 so look for similar functionality with static routes on Router1 instead. Deleting other comments though to keep this cleaner. – Pimp Juice IT Apr 7 '18 at 17:01
  • 1
    So on router1 you somehow need to tell it for 192.168.1.0/24 to send that over to 192.168.0.32 so it sends it there rather than its WAN. – Pimp Juice IT Apr 7 '18 at 17:02
  • 1
    And for what it is worth, I do not believe you ever tried sharing subnets for anything I advised or you said you did so I'm not sure what that is about. It looks like this Vodafone DSL router just doesn't support what you need perhaps and you are SOL or you may need to LAN to LAN for it to work and play with the more robust settings of Router2 if needed. I suppose it would not hurt to call Vodafone and ask them just in case though as they should be able to tell you right away if this is a router they suggested, leased, etc. – Pimp Juice IT Apr 7 '18 at 22:34
1

First of all subnets do NOT share subnet masks. It's just similar in those networks.

It is unclear if you have NAT enabled on Router2. Please check it out. If NAT is enabled, everything should work fine and you should trace any possible issue somewhere else, e.g. if the NAS has proper default gateway.

If you like to have plain routing between the subnets, then proper route must be defined on Router1 or NAS for that to know where (by which IP address, here 192.168.0.32) to find 2nd LAN.

You can check that out with ping or trace from 2nd network:

ping 192.168.1.100
tracert 192.168.1.100
  • NAT is enabled in Router2, and using tracert 192.168.0.100 I get the following result: Tracing route to NAS [192.168.0.100] over a maximum of 30 hops: 1 <1 ms <1 ms <1 ms 192.168.1.1 2 1 ms <1 ms <1 ms NAS [192.168.0.100] Trace complete. – Matthew Correa Apr 11 '18 at 22:01
  • your problem description for routers doesn't mach the picture. you need to connect from 192.168.2.x to \\192.168.1.100\myshare in LAN1. you cannot have a LAN of 192.168.0.x – MTG Apr 12 '18 at 11:19
  • I'm sorry, I can't say I follow, could you somehow clarify? – Matthew Correa Apr 12 '18 at 15:41
  • edited the post. you got these ranges 192.168.1.x and 192.168.2.x, there is no 192.168.0.x in the map. you want to access NAS under router1 to be accessible from LAN under router2. right? – MTG Apr 13 '18 at 7:27
  • Yes, that is correct, although I should mention that router1 uses 192.168.0.x and router2 uses '192.168.1.x'. I assume you got it from the image, although the image is just one I found online. – Matthew Correa Apr 13 '18 at 15:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.