0

I successfully installed and configured knot-resolver on my dedicated server connected through VPN but I can't get it to work on my workstations.

Actually nslookup superuser.com b.b.b.1 on my Win10 workstation gives the correct answer and I can see my resolver is correctly used (not 1.1.1.1).

Now, if I set b.b.b.1 as static DNS server in windows network settings I've got no more name resolution:

  • ping b.b.b.1 is ok
  • nslookup superuser.com is ok and uses b.b.b.1
  • ping superuser.com does not find host
  • any browser can't resolve names

Network is set this way:

LAN
    IP=a.a.a.2/24
    GW=a.a.a.1
    DNS=1.1.1.1 or b.b.b.1
    DHCP=none
VPN
    IP=b.b.b.2/30
    GW=none
    DNS=none
    DHCP=b.b.b.1

kresd listens on b.b.b.1:53 and forwards to my dedicated's WAN.
Flushdns has no effect.

0

Problem solved by setting no DNS on LAN connexion and b.b.b.1 as DNS on VPN connexion.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.