0

The router (RT-N66U) is connected to a network switch (this one), sometimes it works, sometimes it does not. The internet works just fine wireless, power-cycling the switch does nothing, however, directly connecting the computer to the router through an internet cable, letting it acquire a connection, and then connecting the cable back to the switch and the switch to the laptop, does fix the issue. Sometimes it will happen when I reboot into a different OS (happens on both linux and windoWs), sometimes it happens overnight, so and so, it feels somewhat random, but this makes me suspect it has something to do with poor negotiation between the computer and the router when the connection has to go through the network switch, for example the connection dying over-night makes me wonder if it stops working when the DHCP lease expires.

How to fix? pls help

0

There are various potential causes:

  • a bad cable - check the cable for damage, sharp bends, ..., try another cable and check the link lights on the switch & NIC - link should be constantly on, even if you wiggle the connector
  • a bad switch - check with another device, another switch
  • an auto-negotiation problem - unlikely and hard to diagnose with an unmanaged switch - check the router's port status and (if possible) on the laptop; try manual settings to 100 Mbit half-duplex or 10 Mbit half-duplex
| improve this answer | |
-1

It happens rarely nowadays but issue related to auto-negotiation do occur.

The auto-negotiation I speak of is not related to the router but between the computer and the switch, concerning the speed (10/100/1000Gbs) and the duplex mode (half-duplex of full-duplex).

Try manually setting the computer network card to 100Mbs / full-duplex.

On Windows this can be done in the advanced properties of the network cable.

| improve this answer | |
  • "Try manually setting the computer network card to 100Mbs / full-duplex." is really bad advice since the switch port will fall back to half-duplex, creating a duplex mismatch. – Zac67 Apr 9 '18 at 11:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.