1

I have been trying to figure out issues with my wifi setup on my laptop with ubuntu 16.04. For some reason it doesn't seem to connect. Have tried with wicd, network-manager as well as ifconfig. On further debugging, I see that calling dhclient I see this:

sudo dhclient -v wlp1s0

Listening on LPF/wlp1s0/90:cd:b6:97:67:bf
Sending on   LPF/wlp1s0/90:cd:b6:97:67:bf
Sending on   Socket/fallback
DHCPDISCOVER on wlp1s0 to 255.255.255.255 port 67 interval 3 (xid=0x9d8a1621)
...
DHCPDISCOVER on wlp1s0 to 255.255.255.255 port 67 interval 1 (xid=0x9d8a1621)
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

Also when dumping the tcp connections on the given wireless device, I see no outgoing or incoming packets at all.

sudo tcpdump -n -i wlp1s0
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on wlp1s0, link-type EN10MB (Ethernet), capture size 262144 bytes

Just to be sure that there are no iptable rules blocking the outgoing or incoming traffic, I see no filters are set. Also to avoid issues with my router, I verify that it works for other devices handing out dhcp ips and on the same laptop, the ethernet adapter works perfectly.

I am not sure what is going on. Is the device driver a problem or my network configuration?

The wireless h/w is QCA9565 / AR9565 Wireless Network Adapter.

1

Well, DHCP handshake is done via UDP, so don't expect TCP packets for that.

Inspect output of ifconfig and make sure you are dealing with the right interface.

Try disabling network-manager and test dhclient manually once again. There might be some conflicts between new and legacy network services.

Make sure there are available addresses in the address pool of the DHCP server / router of your network. All ip's in the pool might have been consumed by other devices on your network.

| improve this answer | |
  • Well tcpdump shows not only TCP packets but also UDP packets. And I could see that even on another laptop and when I try to run dhclient. I stopped network-manager servic.e before I tried dhclient. And yes dhcp server does have enough ip ranges to allocate one. So none of this is an issue. It seems to be something else. – DivKis01 Apr 8 '18 at 6:54
  • Please share output of ifconfig, route -n along with any other details you came across, in your post. – MTG Apr 8 '18 at 7:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.