1

I recently bought a new case for my PC. I changed everything from my old case to the new one and tried to turn on the PC. It starts, all fans work fine (PSU, CPU, GPU and all case fans). I see the BIOS screen in the monitor and then the PC completely shuts down.

Here's what I tried:

Changing the PSU: I had an old Cooler Master PSU that I already wanted to change because I thought it could fail any minute so I thought that it could have been the problem. I bought a new EVGA PSU, installed it, same problem, so it's not the PSU.

Checking for contact between case and motherboard: Just to make sure there wasn't any short I took out the motherboard, placed it in a cardboard and connected it. The problem is still the same.

Disconnecting my secondary HDD and leaving only the SDD with the OS: Same problem.

Resetting the BIOS: I reset the BIOS with the CLR_CMOS. I tried both the last good configuration and reset to default. After restarting the computer the problem persisted. Note that I can navigate the BIOS config page without problems; it doesn't shut down in the BIOS, but when I restart and try to boot the problem is the same.

This is my hardware:

  • MoBo Gigabyte GA-970A-DS3P
  • CPU AMD phenom II x6
  • GPU EVGA nvidia 750ti
  • RAM HyperX 2x 8GB
  • SDD kingstone 512GB (OS windows 10)
  • HDD Seagate 1TB (only for storage)
  • PSU EVGA 500W

Any ideas? could the motherboard be damaged? Everything worked fine before the case change.

  • Do you have another GPU to use or perhaps try to use built-in video if the mobo has one? Otherwise try putting the GPU into the correct PCIe slot as the default with just ONE on that mobo may need to be a specific one so try with all PCIe slots one by one as that may be the issue. I assume you already set the BIOS to use all defaults, correct? You say reset so I wasn't sure if you also removed CMOS battery for a couple minutes and/or jumper BIOS reset, etc. I got a lot of ideas for you to try.... process of elimination 101. – Pimp Juice IT Apr 9 '18 at 1:56
  • Have you tried disconnecting both your drives and booting from removable media (e.g. linux live disk via dvd or USB)? If you can load that, then your hardware should be fine, and it's the disk / os installation that is at fault. If you can't, then it's a hardware issue. Will narrow down the problem at least. – Baldrickk Apr 9 '18 at 11:23
  • Did you apply new thermal paste to the heatsink after cleaning off the old paste? – Moab Apr 9 '18 at 20:01
1

Try cycling through the HyperX ram sticks. Try one stick in one of the sockets. If it fails to power on try the same stick in the next socket and so forth. If it still fails to power on then do the same procedure with the other stick. Try and rule out the ram and the ram sockets as the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.