6

Why does the following not work from one ubuntu machine to anohter

ssh  user@host mutt

(it just sits there doing nothing)

Whereas the following is fine

ssh  user@host ls 
6

Try using the -t option to ssh, to force it to allocate a pseudo-terminal. For more information, see section 7.4.5.5 of SSH: The definitive guide.

| improve this answer | |
  • @coneslayer - I had seen the pseudo-terminal but didnt understand what it really did. This does the trick for me – justintime Apr 15 '10 at 22:46
  • That -t option is awesome -- thanks so much! – Coderer May 28 '10 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.