0

I have Windows 10 and since last night I have been trying to open command prompt but all it does is launch for a split second where a white window shows up and then it disappears. All while everything else is working perfectly fine, even PowerShell.

These are the ways in which I have tried to open command prompt (none of which have worked, they all result in the same thing described above):

  1. Search in the Start Menu for cmd and launch
  2. Type cmd in run and launch
  3. Go to system32 folder in the root drive and launch cmd.exe
  4. Open task manager and start a new task called cmd
  5. Using a shortcut on my desktop for cmd
  6. opening a batch file

How do I make command prompt work normally? Please help.

Edit 1: So it works when I run it from PowerShell but that still does not solve my issue as when I launch cmd it does not work. Also, I have attached an image of my registry where there is supposed to be a disable cmd that supposedly causes but there is nothing like that.

This is the window that opens for a split second (top right box) when I click cmd No option to un-disable cmd

  • 1
    Have you tried running cmd from within Powershell? – grawity Apr 10 '18 at 12:06
  • I have, check the edit. So, it does technically work, but even if I launch cmd normally it does not work. – Ansh Nanda Apr 10 '18 at 15:57
1

So, I figured out what the problem was. It was a virus installed by some torrent that mined monero by running this program called SoundMixer.exe or Sound Mixer. Opening the cmd leads to launching this program and it can't be detected by most anti-virus software.

Here is the link that explains how to fix it.

  • I've had this issue for some time, I can't believe it came down to this! – Maltanis Nov 17 '18 at 4:14
0

Have you tried going to Start > Run..

And typing cmd /K?

If the above solution does not work, your registry must be having a problem.

Check the following registry setting:

HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\System!DisableCMD

If you see DisableCMD in the location mentioned, remove it.

For a more detailed answer: http://www.tomshardware.com/answers/id-1988202/command-prompt-automatically-closes-open.html

  • Check the edit that I made. The option you said does not show up. The first fix about cmd /K does not work either. – Ansh Nanda Apr 10 '18 at 15:57

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.