1

I used to be able to connect, and now I can't. I have tried uninstalling and reinstalling SSMS. I have not changed my antivirus/firewall settings at all.

OS: Windows 10 Home

TITLE: Connect to Server
------------------------------

Cannot connect to http://[removed].net

------------------------------
ADDITIONAL INFORMATION:

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - No such host is known.) (Microsoft SQL Server, Error: 11001)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&EvtSrc=MSSQLServer&EvtID=11001&LinkId=20476

------------------------------

No such host is known

MORE BACKGROUND:

  • I can connect on my laptop sitting next to my desktop computer. It had the same issue, but I fixed it by uninstalling/reinstalling
  • I'm using SQL Server Management Studio 2017
    • I've tried re-installing both SQL Server 2017 and SSMS 2017
    • I can connect to my local db just fine
  • 1
    It seems to to be listening on TCP port 1433 per the DNS name from this side so be sure you are connecting to the correct port just to ensure that's not the issue. Try again and maybe you had a one time ISP or Internet DNS fluke, etc. Otherwise run nslookup sealingservereastus2.database.windows.net and then try connecting to the IP address that is shows it has.... I saw 52.167.104.0 so check and make sure what that is when you run in case it have a round robin DNS, etc. and try connecting to it via its IP address. Show your connection screen with a screen shot too.... Are you using SSMS? – Pimp Juice IT Apr 11 '18 at 2:48
  • 1
    Check your DNS settings, flush DNS, try connecting to it from a different machine, on a different network, etc. and just be thorough in your testing to eliminate the common type issues as overlooking something simple and basic and wasting time chasing ghosts is never fun. – Pimp Juice IT Apr 11 '18 at 2:49
  • @PimpJuiceIT The "simple and basic" fixes do not seem to be working. Could something be wrong with the install? – Matt Apr 16 '18 at 18:28
  • Check and compare the TCP/IP settings of the one that does work versus the one that doesn't and see if maybe one is LAN and the other is Wi-FI and the DNS settings from ipconfig too perhaps. If it's not network related for however the laptop connects vs the other machine or DNS then perhaps it's something that's corrupt on the install as you are suggesting. Test the connect to this URL on that correct port with both using telnet and see if there are different results between the two with that method?? Did you flush the DNS on the problem machine already and compare NSLOOKUP commands – Pimp Juice IT Apr 16 '18 at 19:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.