1

This question has been asked before, but none of the answers worked for me.

Details

After about 5 minutes and 41 seconds (yes, I timed it), my desktop shows up as normal.

It only happens on one account; other accounts are unaffected.

During the black screen:

  • CPU: ~12%.
  • Disk: ~6%
  • Ethernet: random spikes.

...Which is pretty much equal to my idle usage, once windows starts properly.

Looking at the task manager and sorting by CPU usage, wsappx was the biggest task, at ~12%.

Once Windows actually starts, everything seems to work normally.

Functional things

Ctrl+Alt+Del - Works as expected.
Ctrl+Shift+Esc - Brings up task manager.
Task manager - Works, that's where I got the numbers above from. Doesn't show any foreground tasks running, spare task manager itself.

Non-functional things

Win+R - Nope.
Win+P - Nope.


Device specs

ThinkStation P320 Signature Edition Processor: Intel(R) Core(TM) i7-7700K CPU @ 4.2GHz System type: 64-bit OS, x64-based processor
Graphics card: Radeon(TM) RX 460 Graphics
Full output of dxdiag

Windows

Edition: Windows 10 Pro
Version: 1709
OS Build: 16299.309


If none of the answers below work for you, don't panic! Do research, find one that does, and then post an answer documenting what you did to help others!

  • 2
    Does it have a discrete graphics card? – user772515 Apr 10 '18 at 18:44
  • Yes; HMB while I find out which one. – SIGSTACKFAULT Apr 10 '18 at 19:18
  • 1
    Please edit your questions whenever you need to add additional information. That said, and before anything else, install/update the graphics drivers. – user772515 Apr 10 '18 at 19:30
  • Does it behave the same way if you log in as a different user? How about if you start Windows in Safe Mode? – Ƭᴇcʜιᴇ007 Apr 10 '18 at 20:52
  • @Ƭᴇcʜιᴇ007 Other user accounts are fine; I'll get back to you on the safe mode. – SIGSTACKFAULT Apr 10 '18 at 21:16
0

The black screen only with the cursor may caused by these errors:

  1. Outdated or corrupted Graphics Card drivers.

  2. Problematic applications.

  3. File corruption.

  4. Display brightness errors.

  5. System conflicts.

And you can try to learn more about it with this article: https://windows10skill.com/black-screen-with-cursor-windows-10/

0

First, I updated everything: Windows, graphics card drivers, etc. Reboot to apply.

Then, I started regedit, and made these changes. In
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\AppXSVC and HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\ClipSVC

Change the "Start" REG_DWORD value from 0x3 to 0x4.

Reboot to apply.


This can be achieved with this .reg file:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\AppXSVC]
"Start"=dword:4

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\ClipSVC]
"Start"=dword:4

Paste into a file, save it as killwsappx.reg, double-click.

0

I had a similar problem and it turned out to be the exlporer.exe process (which renders the icons on your Desktop and deals with your Taskbar etc.) that wasn't starting up properly.

Press Ctrl+Shift+Esc to bring up the Task Manager, click on File and then on Run new task. Then enter explorer.exe.

-1

I tried everything to fix this, new user account, sfc, dism, safemode, etc and nothing worked. This worked on the first try. Unbelievable! The only issue I ran into is that booting into command prompt mode, not safe mode with command prompt, changed the location where my c: drive was. It boots to x: and when looking at c:, there was nothing there. I also have two other drives, so instead of d: or e:, my c: was located at e:. When selecting e: I then saw my windows folder and everything else on c:. Then I was able to rename, move, or delete the files below.

https://answers.microsoft.com/en-us/windows/forum/apps_windows_10-winapps-appscat_productivity/windows-10-start-button-get-appxpackage-also-not/1eddb653-252c-4fbf-a9eb-adb88169cf5e

Crantex replied on Jan 3, 2018...here's part of what he wrote.

"Rather than set up a scheduled task as described there I rebooted my machine into a command prompt (not safe mode but a command prompt) and renamed the following files:-

C:\ProgramData\Microsoft\Windows\AppRepository\StateRepository-Deployment.srd C:\ProgramData\Microsoft\Windows\AppRepository\StateRepository-Deployment.srd-shm C:\ProgramData\Microsoft\Windows\AppRepository\StateRepository-Deployment.srd-wal C:\ProgramData\Microsoft\Windows\AppRepository\StateRepository-Machine.srd C:\ProgramData\Microsoft\Windows\AppRepository\StateRepository-Machine.srd-shm C:\ProgramData\Microsoft\Windows\AppRepository\StateRepository-Machine.srd-wal e.g. C:\ProgramData\Microsoft\Windows\AppRepository\StateRepository-Deployment.srd renamed to C:\ProgramData\Microsoft\Windows\AppRepository\StateRepository-Deployment-Corrupted.srd"

-1

Windows 10 home 64 bit v 1709 build 16299.371 - 2 users core i5-6600 8GB,GeForce GTX 970 I did system restores, tried most of the suggested solutions but the problem kept coming back for one user. Finally removed and reinstalled the user. OK for a week now. Life's too short to be wasting precious time with a piece of plastic.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.