I have created a NTFS Partition(/dev/sda3) and copy the grub files in it in the following path: /dev/sda3/boot/grub/

then tried to install the grub by using following commands:

grub> root (hd0,2)

 Filesystem unknown, partition type 0x7

grub> setup (hd0)

 Error : cannot mount selected partition

The partition is present and i created it with gparted.

i also tried the following command:

find (hd0,2)/boot/grub/stage1

Error 15: File not found

All the files were there as copied them. So, where is the problem and what i am doing wrong?

  • what version of grub are you using? is this Grub4DOS? Apr 15, 2010 at 15:58
  • i am using grub in fedora 12. But i found the problem, I think grub can't handle NTFS partitions. I just format the partition with FAT32 and then copy the grub files as earlier and now grub installation worked great. So, is there any way to install grub on NTFS partition?
    – MA1
    Apr 15, 2010 at 16:06
  • yeah, i don't think so. but grub legacy (aka Grub 1) and Grub 2 are different systems and one may support NTFS while the other doesn't. Apr 15, 2010 at 16:20
  • will the grub2 can handle NTFS?
    – MA1
    Apr 15, 2010 at 16:47

1 Answer 1


The problem is due to no NTFS support in GRUB.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.