I have an virtualized ubuntu server 16.04.4 instance (from osboxes.org) that I run with virtual box.

It runs smoothly with a single core, but as soon as I add another cpu it won't start up: Freeced screen The exact point when the system freezes (like shown in the screenshot above) changes from one start to another.

Here are my current settings: Settings 1 Settings 2

I tried different numbers of cpus. IO-APIC is active as found on other sources. Nothing changed here. Thanks for your help


  • I'm running this on my laptop, HyperV is enabled.
  • Processor is Intel i7-4700MQ (4 cores, 8 threads)
  • I have 16gb of ddr3 ram

  • I have installed the current stable version of Virtual Box, 5.2.8

  • What version of VirtualBox are you using? What CPU do you have? If your CPU is a dual-core (and 4 threads), of course you can't assign both physical cores to the guest. – Tiago Caldeira Apr 13 '18 at 11:15
  • @TiagoCaldeira You can assign as many threads as you have physically available. So actually assigning 4 threads of a 2-core CPU is allowed. – gronostaj Apr 13 '18 at 11:27
  • @Karl - You need to provide us hardware information. Edit your question to include this required information into the body of your question. – Ramhound Apr 13 '18 at 12:10
  • @gronostaj My bad then. But the host machine need CPU too, it couldn't break your system by assigning all threads to the guest OS? – Tiago Caldeira Apr 13 '18 at 12:12
  • As @Ramhound says, and also check if you have the virtualization options enabled in the BIOS (VT-x or Hyper-V). – xenoid Apr 13 '18 at 12:14

I created a new vm, using the same image.

I added 4 cores initially and everything works fine. I even can remove and add cores now without any issues.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.