I have a Logitech Revolution VX, a small portable mouse. I use it on my laptop running Windows 7 64bit Professional.

When a UAC prompt comes up, I can use the mouse to move the pointer, however any clicking via the external mouse does not register. I have to use my trackpad to actually click. This continues on into whatever UAC window comes next, such as a program install. The mouse pointer can move via my external mouse, but no button clicks register except on the trackpad.

This also happens if I am to right click a program and select "Run as Administrator". The external mouse will move the pointer, but no button clicks work.

I've tried to google for this issue but haven't found anything. To be it seems generally a problem with my external mouse driver not running with elevated privileges itself.

Any help would be appreciated.


There has to be a way to do this legitimately: If I take the exact same mouse and plug it into my desktop (also Windows 7 64bit), the mouse clicks do work on UAC prompts and elevated privilege programs.

  • For what it's worth, Googling "logitech +uac" turns up a LOT of results also containing the word "disable" - it seems as though Logitech and UAC don't get along well at all. Apr 15, 2010 at 19:18
  • Yes, especially frustrating since I never ran Vista, so I'm perfectly comfortable with UAC in Windows 7 (almost 2 months now of use). Not particularly interested in disabling it. Apr 15, 2010 at 19:37

1 Answer 1


I've seen the very same thing with the Logitech Touch Mouse Server (an iPhone app / server combo that lets me use my iPhone as a touchpad mouse on my HTPC). When prompted by the UAC, I have to go plug in a keyboard or mouse to be able to interact with it. I assumed, like you do, that it has to do with the driver not being elevated enough to interact with the UAC (although with my setup, I'm okay with that, because it's a piece of software doing the emulation - imagine if a hacker could get an emulator installed and acknowledge UAC prompts!)

In your case, I assume you've installed the Logitech software/driver that came with the mouse. Have you tried using the mouse without those drivers? Perhaps using standard Microsoft drivers will allow you to interact with the UAC (although you might lose special functions like forward and back buttons on the mouse, etc).

  • Yes, that would be a huge problem for me if I lose Logitech functionality as well as the uberOptions modification to the Logitech package itself. I would like a way around this - how do I have the Logitech programs run as administrator? Apr 15, 2010 at 18:51
  • I don't think that it's even their software - I think it's something in their actual mouse driver software. I am not able to even move the mouse with my iPhone when I get a UAC. Since you can move it, the only thing I can imagine is that the Logitech driver sends the mouse click to a piece of software that the UAC won't allow to interact with it. Worse-case scenario, I guess you could always disable the UAC (although, personally, I wouldn't). Apr 15, 2010 at 19:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .