6

When I re-open Chrome, it brings back more tabs than I had when closing it.

The extra tabs are tabs that I recently closed (can be 30 min ago). I close Chrome with 5 tabs and come back to 8. They also doesn't necessary come back in the same order they were before.

From the things I tried and didn't helped (some of them from the answers):

  • Update Chrome to the most recent stable version.
  • Disabling all extensions and apps (including background).
  • Cleaning some caches from the browser.
  • Disabling and enabling the "Continue where you left off" feature.
  • Creating a new Chrome user (exist also in the new one).
  • Enabling or disabling chrome://flags/#enable-fast-unload doesn't change anything.
  • Looking for access denied with procmon, nothing useful.

Example:

enter image description here

Any ideas? (which are not just to try to uninstall completely and try again).

Thanks!


Google Chrome version details: 65.0.3325.181 (Official Build) (64-bit) (cohort: Stable)
New version, still valid: 66.0.3359.117 (Official Build) (64-bit) (cohort: 66_117_win)


UPDATE: Solved it with TontyTon's last idea, although it included an uninstall, which I don't think is a good solution (in almost all cases) - but at least all of my user data was kept.

1
  • This may not be related to OP's problem directly, but I did have the same problem. However, in my case I was using multiple desktops (Windows virtual desktops via Task View). And having other chrome windows open there, kept popping open empty Chrome windows on "resume". Ensuring I had "ALL" Chrome windows closed fixed my issue.
    – Mark
    Apr 17 '20 at 15:04
2

There have been in the past numerous complaints about this behavior, expressed in bugs issues #128523 and #110324.

These bug reports are not new, but they contain many workarounds that posters in these threads said have fixed this problem. Below is the list of these workarounds :

  • versify if chrome://flags/#enable-fast-unload is set to Disabled.

  • Locate the Google Hangouts extension and disable it in Chrome menu -> More Tools -> Extensions. If the problem was solved, you may reinstall Hangouts from the Play Store.

  • Disable Google Print

  • Try to use the extensions Continue where you left off or TabCloud.

  • Uninstall and re-install Chrome

2
  • Thanks for your answer! 1) #enable-fast-unload was enabled (I tried re-enabling); 2) about the extension - I tried it when I tried disabling all the extensions, didn't changed anything; 3) Couldn't find how to be sure it's done - there's no disable in Chrome settings, no local service nor printer/device related. The Google Cloud Printer only shows the "Save to Google Drive" option. I tried disabling anything related in chrome://flags and local services. Any hint on that disabling? 🙏 Apr 23 '18 at 12:33
  • About the extensions - the first one is almost great, but it's a bit buggy and it opened some tabs multiple times when I played with it for a few minutes. The second one is for syncing across devices and it forces me to save manually :/ Apr 23 '18 at 12:46
2
+50

Try the following steps:

1) Update Chrome, if update available (obviously).

2) If you are using any third party software to clean temp files, then white- list Google Chrome from that. Some of these softwares remove files which are important for such features (Continue where you left off).

3) You should also try:

  • Firstly, switch to 'Open the new Tab page' option, refresh Setting page, close Chrome (completely).
  • Now start Chrome again and switch back to 'Continue where you left off', refresh Settings page, without opening other tabs close Chrome (again completely).

Now test if 'Continue where you left off' is working or not.

If no suggestions work (even from others) then:

a) Copy your profile from 'C:\Users\\AppData\Local\Google\Chrome\User Data'.

It will be 'Default' if you only have one profile, otherwise it may be 'Default', 'Profile 1', Profile 2', etc. (Remember to copy all profiles)

b) Reinstall Chrome.

c) If only one Profile: Paste the copied profile by selecting 'Replace all files'

If had many profiles: Make same number of profiles, then paste the files.

This will work, without the loss of your bookmarks, history, etc.

2
  • Thanks for your answer! None of the first part of the suggestions worked, maybe I'll try to save my profile data as you suggested as a last thing before completely re-install Apr 23 '18 at 11:56
  • Although I don't like it, cause it doesn't address the core problem and still uses the re-install generic solution - I saved the Profile folder, re-installed chrome and set the old folder back - solved. At least that way it was less uncomfortable (since all of my data was kept). Apr 29 '18 at 16:21
1

Two more things I would try (though somewhat similar to "just to try to uninstall completely and try again"):

  1. Disable running background apps in the settings page -> advance -> system

  2. Reset Chrome settings in the settings page -> advance -> reset

1
  • Thanks for your answer! the first one did not help, and the seconds one is actually the same as uninstalling :( Apr 23 '18 at 11:26
1

Common cause: multiple Chrome windows

There is an underlying complication with the "continue where you left off" (CWYLO) function, in that it only uses the tabs from one window. If you at any point have several Chrome windows open, you may find that the tabs in one window get wiped, because Chrome was using the other window to determine the recent tabs for CWYLO. I've not managed to figure out how to control which window it looks to for CWYLO.

This problem will occur if you use the "create shortcut" function in Chrome (menu --> more tools --> create shortcut), to have a specific webpage open in a new window as a standalone web app. If you have this page open when you open you main browser window, you will possibly lose your recent tabs in your main browser window, as Chrome looked to the open web app to get its CWYLO recent tabs.

Workaround solution

If you work with multiple Chrome windows or shortcut-based "web apps", you can work around the issue by making sure that all other Chrome windows (including web apps made using the "create shortcut" option) are closed before closing your main browser window, and are closed before opening your main browser window.

-1

Open Chrome -> settings ->Advanced -> System ->

"Continue running background apps when Google Chrome is closed"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.