1

At my workplace, one of the computer has problems accessing “https://” websites. It only occurs to this machine and with web browsers Chrome and Firefox; Internet Explorer works with almost no problem at all.

I’m aware that most of the time this happens because the pc has the wrong time and/or date, but I already checked them and they are correct, the issue will also occur during incognito mode so is not the fault of any extension on the browsers.

Did some research and it seems like the issue is with a broken security certificate “ParentsonPatrol” that for some reason takes control of the security certificate of all the https websites making them inaccessible.

Tried searching this software on the computer but is nowhere to be found and I already tried the ipconfig commands on CMD, those fix the issue but it doesn’t last for too long, the “ParentsonPatrol” certificate returns after restarting or turning on the machine making it impossible to go to any https site.

This is how it looks like before and after the “ParentsonPatrol” takes over the security certificates.

Before:

enter image description here

After:

enter image description here

  • Have you requested the assistance of your workplace's IT personnel? They will have more knowledge of your computer's configuration, internet gateway configuration, internet security configuration, and so on. – Jeff Zeitlin Apr 17 '18 at 12:55
  • They don't seem to know about it, a lot the pcs here have viruses and/or corrupted antiviruses. – Cesar Apr 17 '18 at 13:16
  • Then you seem to have more serious problems than merely https failure, and your IT people aren't doing their job. – Jeff Zeitlin Apr 18 '18 at 8:46
  • Mmm, not good. Forged certificates from ParentsOnPatrol exist legacydirs.umiacs.umd.edu/~tdumitra/courses/ENEE757/Fall15/… (also mentioned here) – Jan Doggen Apr 24 '18 at 14:34
  • I see in several search results ("parentsoncontrol certificate") that ParentsOnControl is mentioned in relation to McGruff. Here is another user with the issue, but no solution. Scan your registry for ParentsOnControl and McGruff – Jan Doggen Apr 24 '18 at 14:41
2

You need to remove ParentsonPatrol to fix this problem. You're having an issue because the parental controls market is an ugly mess of nonsense. I can remember someone like Nancy Grace or some other similarly overpaid scare monger spouting how HTTPS sites encrypted traffic, so parents couldn't see what their kids were getting into, so some apps for parental control forbade all HTTPS traffic as an option or default. They still do, and pitch it as a selling point to school systems.

Nowadays, HTTPS is considered the safer approach due to phishing, so any of this legacy garbage needs to go. Unfortunately, the difference between parental control apps and certain forms of malware is negligible. Half the time, I've had to wipe machines to get rid of hyperactive parental controls. If parental controls must be used on a machine, I recommend software which defaults to lower security measures and allows the administrator to increase those measures instead of the other way around, and nothing that ever prevents the administrator from having full permissions on the machine.

| improve this answer | |
  • Is there any way to find this "ParentsonPatrol"? I tried searching on the windows search bar, the pc folders and in "add or remove programs", there is not trace of parentsonpatrol or any parental control software – Cesar Apr 17 '18 at 13:19
  • 1
    That's probably why it's gone nuts on you. If the app was uninstalled but the crap from it was left behind. The current "Parents On Patrol" app I was able to find is mobile only, so this is either legacy or a virus. Either way, really, it's malware, so take the malware approach. Delete the cert, boot into safe mode, and see if the cert reappears. If it does, it installed a rootkit that needs removing. If it doesn't, then it's registry digging time. – CDove Apr 17 '18 at 13:24
  • Sorry for the late response. I can confirm that if I delete the certificates on the browsers and put the pc on safe mode, the cert won't appear; but restarting the pc and after using it for a while ParentsonPatrol would return. Couldn’t find any reference to the software on regedit, I did however find a file named eventagent.dll on the system folder that is related to the ParentsonPatrol Company, unfortunately deleting it didn’t solve the issue either. – Cesar Apr 17 '18 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.