9

I have three Windows 10 machines on a network, on the same default network: WORKGROUP.

One of them can see all three, call it Media-PC. The other two can only see each other but not Media-PC, call them desktop-1 & desktop-2.

I have turned on the following services, DNS Client, Function Discovery, SSDP Discovery & UPnP Service.

Network discovery is running on all three machines. I can ping all three computers from each other.

I cannot figure out why desktop-1 & 2 can't see Media-PC.

Media-PC can see them but they can only see each other.

Hope someone can help me with this.

  • Disable the firewall on Media-PC and try again. – Appleoddity Apr 18 '18 at 5:18
  • That didn't make a difference. – Anders Kitson Apr 20 '18 at 16:15
  • 1
    All of the network adapter properties are setup exactly the same across the three machines as you can see here cl.ly/3a250Z3Z1U12 I don't know where to find the TCP/IP settings when you refer to DNS, Default Gateways. All the firewalls are turned off and still no luck. two of the machines are Ethernet and one is wifi, the router doesn't have wifi isolation turned on, and link layer is checked as you can see in my link. Not sure what to do. – Anders Kitson Apr 21 '18 at 2:40
  • Is Media-PC the one one using the Wi-Fi? If so, does WI-Fi get DHCP from another source than the LAN? – Pimp Juice IT Apr 21 '18 at 4:07
  • Media-Pc is on ethernet. – Anders Kitson Apr 21 '18 at 4:16
13
+50

Network discovery has since always been a painful subject in all versions of Windows, especially now when so many security fixes were applied.

I have collected below all the fixes I know. You might try them one by one, undoing the ones which do not help.

Homogenous account types

All the computers must be logged-on with the same type of account. Meaning that all must have a Microsoft account or a local account, as mixing account types will not work.

If you change an account type that has created some network shares, they should be deleted and recreated.

Network Reset

In PC Settings, Network & Internet Settings, click Network Reset and in the next screen click Reset now.

This will reset all network settings, so you may have to recreate any defined VPNs and re-enable settings such as Network Discovery.

Computer Browser service broken

As described in the Microsoft article SMBv1 is not installed by default in Windows 10 Fall Creators Update 2017 and Windows Server, Semi-annual Channel says :

The Computer Browser service relies on the SMBv1 protocol to populate the Windows Explorer Network node (also known as "Network Neighborhood"). This legacy protocol is long deprecated, doesn't route, and has limited security. Because the service cannot function without SMBv1, it is removed at the same time.

However, if you still have to use the Explorer Network in home and small business workgroup environments to locate Windows-based computers, you can follow these steps on your Windows-based computers that no longer use SMBv1:

  1. Start the "Function Discovery Provider Host" and "Function Discovery Resource Publication" services, and then set them to Automatic (Delayed Start).
  2. When you open Explorer Network, enable network discovery when you are prompted.

All Windows devices within that subnet that have these settings will now appear in Network for browsing. This uses the WS-DISCOVERY protocol. Contact your other vendors and manufacturers if their devices still don't appear in this browse list after the Windows devices appear. It is possible they have this protocol disabled or that they support only SMBv1.

If this does not help, you may enable SMB 1.0/CIFS File in Programs and Features -> Turn Windows features on or off. Enable both the SMB 1.0/CIFS Client and Server. The disadvantage is that you will be vulnerable to viruses that exploit SMB v1.0 vulnerabilities such as Wanna Cry, although one of your computers must first be infected for the virus to propagate to the others using this vulnerability.

Re-check network Discovery

In an elevated Command Prompt run

netsh advfirewall firewall set rule group="Network Discovery" new enable=Yes

Required Windows services

In the Services console, ensure the following services have a Startup type of "Automatic" and status is "Running".

  • Function Discovery Provider Host - Automatic (Delayed Start)
  • Function Discovery Resource Publication - Automatic (Delayed Start)
  • DNS Client - Automatic
  • SSDP Discovery - Automatic
  • UPnP Device Host - Automatic (if you use UPnP)

Missing master browser computer

Use regedit on the computer you wish to always be the master browser, and navigate to the registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters

Change the value of MaintainServerList from Auto to Yes.

If it is missing, add a new String Value IsDomainMaster and set it to True.

You may need to reboot to activate this.

For more information see Specifying Browser Computers.

Add credentials for other computers

If you cannot see shares created by other computers, you may need to add reciprocal credentials to both computers.

Go to Control Panel, User Accounts, Manager your credentials, and click on Windows Credentials. Now click on Add a Windows Credential.

Add all your users as follows :

  • Internet or network address: The name of the other computer
  • User name: Other computer name or Microsoft account email address
  • Password: other computer's logon password

Press OK to save. A Network Reset might be required.

Check sharing options for your network profile

In Control Panel -> Network and Sharing Center -> Change advanced sharing settings, ensure that all "Turn On ..." and "Allow ..." options are checked for your type of profile (normally Private).

Rebind all network adapters

For hard problems, uninstalling all network adapters in the Device Manager and reboot may help. After the reboot, Windows 10 automatically re-installs the network adapters.

  • I tried a number of your solutions the masterbrowser fix and restart has seemed to be what worked, it's not perfect because some of the machines don't see eachother but they all see the media-pc which was my goal. – Anders Kitson Apr 22 '18 at 19:40
  • There is also the possibility of joining all the computers to one HomeGroup, which might help. Tutorial is here. – harrymc Apr 22 '18 at 19:47
1
  • Make sure all of the three computers are on the same network IP.
  • Make sure all of the three computers have the same subnet mask IP.
  • Make sure to check the local IP address of the three computers using ipconfig

Make sure you have everything needed enabled inside Control Panel.

  1. Open Control Panel
    enter image description here
  2. Choose "Network and Internet"
    enter image description here
  3. Choose "Network and Sharing Center"
    enter image description here
  4. Change adapter settings
    enter image description here
  5. Right click on your network adapter and choose "Properties"
    enter image description here
  6. Check the both Link-Layer Topology Discovery extensions
    enter image description here


After finishing that, you should be able to discover all of the three PC's from any one of them. If not, try restarting the PC. Good luck!

sincerely,
Nurudin Imširović

0

I recently faced the same issue after installing some possibly bad network drivers. If harrymc and Nurudin's solutions doesn't work, try running the commands net view and nbtstat -a DEVICE, more detailed instructions.

If nbtstat -a DEVICE returned back an error like NetBT is not bound to any devices, you can try to manually bind it via editing the Registry directly (Regedit is risky, do at your own risk), instructions from RGeorge68:

"I found a registry entry (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Linkage) that has values containing lists of interfaces. The guid of the lan card (taken from HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkCards) was not in any of those lists, so I've added to them and restarted. Now netbios was enabled on LAN but shares were not accessible. I found further registry keys for smb (HKLM\SYSTEM\CurrentControlSet\Services\Lanmanager and lanmanagerworkstation) and amended the lists there too. After restarting shares started to work at some extent."

Once nbtstat -a DEVICE works, try seeing if all the computers can discover each other now. This is what solved the issue for me.

Not the answer you're looking for? Browse other questions tagged or ask your own question.