I'm trying to transfer some files over LAN from a Windows 10 PC to a Mac and it's incredibly slow around 2 MB/s.

I've tried the following with exactly the same files.

  • Transfer from my PC to another PC everything works great around 100 MB/s
  • Transfer from another PC to the MAC again around 100 MB/s
  • Unplug Ethernet cable from my pc and switch to Wifi still slow
  • Plug the Ethernet cable from the other PC into mine and still slow.
  • Disable Windows AV
  • Update Windows
  • Turn off Remote Differential Compression API Support
  • Use IP address instead of machine name

I'm completely out of ideas, I'm pretty sure it's my machine considering that the transfer speed from the others is OK.

It really looks like it has something to do with my machine, I just can't figure out what.

Extra info

  • Windows 10 Pro 1709 Build 16299.371
  • Alienware 17 R4 with a Killer E2500 Gigabit Ethernet Controller
  • It's not a direct connection to the PC we use a router
  • Files are copied with Windows Explorer

Looks like the entire problem was caused by the an app that came with the Ethernet Card called "Killer Control Center". In order to fix it you have to go to Settings and turn off Advanced Stream Detect

enter image description here

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .