1

In the English Version of Windows 10 (Maybe 8, 7 have the same problem), If a file's filename is Chinese, Korean, Japanese or other non-ASCII language. Even if the fonts which support this language were installed. There was no change in Windows File Explorer.

The problem of fonts display in Windows File Explorer is:

  1. Some of non-ASCII characters are displayed as the wrong appearance.

  2. Some of non-ASCII characters is displayed in a very small size.

And the problem in CMD is:

  1. The encoding of cmd does not support non-ASCII character. (Or the deeper layer does not support non-ASCII). When I start some executable file, if its name include non-ASCII character, it can not run. And when I try to run .bat or .cmd file include non-ASCII character in it, it will raise error.

I have install adobe open source fonts which support those non-ASCII characters.

Q1. However how to modify the font which Windows File Explorer use?

Here is the example of error in Windows File Explorer: enter image description here Forgive me that I am not a Chinese native user, but have some fundamental knowledge. Those letter should be like this picture:

enter image description here

The third line of example is not in right size.

Q2. How to make shell layer support Unicode characters?

2

For the display of characters in a language which was not configured in Windows 10, you need to install the language. This is in PC Settings -> System -> Apps & features -> Manage optional features -> Add a feature, then select any optional font feature from the list.

You will find more info in the Microsoft article Why does some text display with square boxes in some apps on Windows 10?. The section "Details on font changes in Windows 10 Desktop" contains details about packages which use some rare font features that do not have their own languages.


For the wrong display of Chinese characters (or others), try this :

  • Go to Control Panel -> Fonts -> Font settings and unclick the option Hide fonts based on language settings.

  • In Control Panel - > Region, click the Administrative tab, then under Language for non-Unicode programs, click Change system locale. If you're prompted for an administrator password or confirmation, type the password or provide confirmation. Select the Chinese language and click OK.

| improve this answer | |
  • I have already installed these features. But it still does not work. I think the reason is the default font of Windows file explorer does not support non-ASCII character. And the most possible solution I think is change the font of Windows file explorer. – pah8J Apr 18 '18 at 23:09
  • And it is not display as square boxes. it is just weird. I think it is because of the poor support of the default font. – pah8J Apr 19 '18 at 1:34
  • 1
    Adding more info about the languages/characters involved and screenshots of the weird characters display will help to better understand the problem. – harrymc Apr 19 '18 at 6:13
  • Thanks, However I do not think change system locale is a good Idea, Because a lot of 3rd part application is auto-config according to this setting. If I change it, a lot of chaos will be caused. However If I set it to China, Japanese and Korean character are still unable to be displayed properly. Is there any better way? – pah8J Apr 20 '18 at 0:58
  • This setting doesn't change the system locale, just the one used for non-Unicode programs. You might ignore it - it doesn't relate to Windows Explorer which is a Unicode program. The puzzling thing for me here is that as Unicode includes Chinese, Japanese and Korean, the display must be correct. I'm starting to think that the problem might not be on your side but with the source of these files. Is it possible that this source might not use Unicode and is doing an incorrect translation to Unicode when sending you the files? – harrymc Apr 20 '18 at 5:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.