0

On a Toshiba P35W-B3226 with Windows 10 installed to internal SSD, I have created a dual-boot Windows 10 / Ubuntu 14.04.5LTS machine with Ubuntu 14.04.5 installed on a 64 GB USB pendrive. I used Rufus to create an install USB device using the 14.04.5 Desktop ISO (since the Toshiba has no CD/DVD drive) and installed 14.04.5 successfully on the destination USB using the "Something Else" selection during the Ubuntu install, creating a primary partition on the destination USB drive to hold the bootable / executable Ubuntu O/S. However, I have encountered a couple of problems:

  1. Setting BIOS Boot Order ("Power ON-F2") to "HDD first"/"USB second" gives me the GNU GRUB v2.02 command prompt whether the USB with Ubuntu is inserted or not. I expected it to just boot Windows 10.
  2. Setting BIOS Boot Order to "USB first" / "HDD second" with USB attached gives me a GRUB GUI menu with: Ubuntu, Advanced options for Ubuntu, Windows Boot Manager (on /dev/sda2), System Setup. This is the only way I can boot to Windows 10, i.e. USB attached, BIOS boot order "USB first".

My hope-slash-expectation was that to boot Windows 10, I would just change the BIOS boot order with "HDD first" (with no USB attached); for Ubuntu, "USB first" (with USB attached). GRUB appears to have a presence on my SSD now.

Is there a way that I can get my desired behavior?

As an alternative, once I get the GRUB command prompt ("HDD first", no USB attached configuration), is there a way I can tell it to boot Windows without the Ubuntu O/S USB attached?

GRUB "ls" yields: (hd0) (hd0,msdos1) (hd1) (hd1,gpt6) (hd1, gpt5) (hd1, gpt4) (hd1, gpt3) (hd1, gpt2) (hd1, gpt1)

I looked through some superuser.com answers that were similar, but they didn't appear to be close enough to my configuration.

0

You have configured a dual boot with chainloading of windows.

This is the common way to do this and in some cases the only one.

To achieve what you ask, you shouldn't have touched anything regarding boot, just install ubuntu on the USB drive and changed the boot order to USB first. This way the system will normally boot to Windows, but will boot to ubuntu when the USB is present.

Please keep in mind that:

  • live distros on USB 2.0 are slower than proper installation
  • ubuntu 14.04 is less than a year from EOL and a new LTS has just been released
  • Thx for your input on what possibly happened. However, I didn't touch anything regarding boot options; just installed Ubuntu from the "Rufus-ized" ISO on one USB to the destination USB. Perhaps when I selected "Something Else" during Ubuntu installation and had to create ext4 primary partition on the destination USB, there were some residual effects. Re: 14.04 - yeah, it's old, but I was working my way through an Android book and wanted to duplicate the dev environment mentioned exactly. – mikefo Apr 20 '18 at 0:36
  • Is there a way to undo this, i.e. such that, without the USB installed, it will boot directly into Windows10 without giving the cmd-line grub menu? Don't care if I can never boot from the Ubuntu USB. Note that I can still get to Windows through grub "graphics-based" menu, but note I don't have an internal CD/DVD. – mikefo May 3 '18 at 15:41
0

I had this same problem with installing Ubuntu within Windows 10. With Windows being installed first, I had hoped that it would be the default boot first. But no, Ubuntu took over that spot and it would always boot to Ubuntu first. then one day I started searching google to find a way to fix it because I was either going to remove Ubuntu, or fix it. And somewhere, i found a solution. It seems that if you wait for it to boot, there is an option on the screen to change the default boot to Windows. I guess I had never paid that close attention to it.

So, If your booting Ubuntu from a USB stick, and it still tries to boot Ubuntu with the USB stick not plugged in, closely watch the boot up process. You should be given an opportunity to change the default boot up, before it goes automatically to Ubuntu. Worked for me, so I didn't have to remove Ubuntu after all!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.