0

I have asus P7P55 LX motherboard. Yesterday I tried updating BIOS with special asus utility on win10 and after completing the process I got a BSOD. Now my PC does not work. Immediately after powering it on i see BIOS error end recovery thingy asking me to put in USB or CD-ROM with BIOS. https://i.imgur.com/Kzxk3IK.jpg

No matter what I try, I can't get it to work. When I put in my asus CD that come with the motherboard recovery says that Iamge is outdated and asks me to restart pc with no result. Whey I download BIOS for my mobo and properly rename it to P7P55LX.ROM it always said that this file is not found. I tried different bios versions, different usb drives, tried fat32, fat, burned it on CD, but each time it says that P7P55LX.ROM is not found. If I copy rom file from original CD and put it on USB drive it still says that file is not found even that it find it on original CD but complins about it being outdated. I also tried taking out battery, and resetting with that jumper thingy.

Can something be done?

  • Unfortunately it sounds like you bricked your device – Ramhound Apr 21 '18 at 8:04
0

Also I hear beeps when "File not found" message appears. I hear 3 beeps, then it pauses for a second, and then there is 5 more beeps. Don't know if those are short or long though.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.