Doing apt-get update gets the following errors:

Ign http://security.debian.org squeeze/updates Release.gpg
Ign http://security.debian.org/ squeeze/updates/contrib Translation-en
Ign http://security.debian.org/ squeeze/updates/contrib Translation-en_GB
Ign http://security.debian.org/ squeeze/updates/main Translation-en
Ign http://security.debian.org/ squeeze/updates/main Translation-en_GB
Ign http://security.debian.org/ squeeze/updates/non-free Translation-en
Ign http://security.debian.org/ squeeze/updates/non-free Translation-en_GB
Ign http://security.debian.org squeeze/updates Release
Ign http://security.debian.org squeeze/updates/main Sources
Ign http://security.debian.org squeeze/updates/contrib Sources
Ign http://security.debian.org squeeze/updates/non-free Sources
Ign http://security.debian.org squeeze/updates/main amd64 Packages
Ign http://security.debian.org squeeze/updates/contrib amd64 Packages
Ign http://security.debian.org squeeze/updates/non-free amd64 Packages
Err http://security.debian.org squeeze/updates/main Sources
  404  Not Found [IP: 2001:a78:5:1:216:35ff:fe7f:6ceb 80]
Err http://security.debian.org squeeze/updates/contrib Sources
  404  Not Found [IP: 2001:a78:5:1:216:35ff:fe7f:6ceb 80]
Err http://security.debian.org squeeze/updates/non-free Sources
  404  Not Found [IP: 2001:a78:5:1:216:35ff:fe7f:6ceb 80]
Err http://security.debian.org squeeze/updates/main amd64 Packages
  404  Not Found [IP: 2001:a78:5:1:216:35ff:fe7f:6ceb 80]
Err http://security.debian.org squeeze/updates/contrib amd64 Packages
  404  Not Found [IP: 2001:a78:5:1:216:35ff:fe7f:6ceb 80]
Err http://security.debian.org squeeze/updates/non-free amd64 Packages
  404  Not Found [IP: 2001:a78:5:1:216:35ff:fe7f:6ceb 80]
25% [Connecting to ftp.de.debian.org (141.76.2.4)]^C
root@ks3309152:/# nano /etc/apt/sources.list
root@ks3309152:/# nano /etc/apt/sources.list.backup
root@ks3309152:/# nano /etc/apt/sources.list
root@ks3309152:/# apt-get update
Ign http://debian.mirrors.ovh.net squeeze Release.gpg
Ign http://debian.mirrors.ovh.net/debian/ squeeze/main Translation-en
Ign http://security.debian.org squeeze/updates Release.gpg
Ign http://debian.mirrors.ovh.net/debian/ squeeze/main Translation-en_GB
Ign http://security.debian.org/ squeeze/updates/main Translation-en
Ign http://security.debian.org/ squeeze/updates/main Translation-en_GB
Ign http://debian.mirrors.ovh.net squeeze Release
Ign http://debian.mirrors.ovh.net squeeze/main Sources
Ign http://security.debian.org squeeze/updates Release
Ign http://debian.mirrors.ovh.net squeeze/main amd64 Packages
Ign http://security.debian.org squeeze/updates/main Sources
Ign http://security.debian.org squeeze/updates/main amd64 Packages
Err http://security.debian.org squeeze/updates/main Sources
  404  Not Found [IP: 2001:a78:5:1:216:35ff:fe7f:6ceb 80]
Err http://security.debian.org squeeze/updates/main amd64 Packages
  404  Not Found [IP: 2001:a78:5:1:216:35ff:fe7f:6ceb 80]
Err http://debian.mirrors.ovh.net squeeze/main Sources
  404  Not Found [IP: 2001:41d0:202:100:213:32:5:7 80]
Err http://debian.mirrors.ovh.net squeeze/main amd64 Packages
  404  Not Found [IP: 2001:41d0:202:100:213:32:5:7 80]
W: Failed to fetch http://debian.mirrors.ovh.net/debian/dists/squeeze/main/source/Sources.gz  404  Not Found [IP: 2001:41d0:202:100:213:32:5:7 80]

W: Failed to fetch http://debian.mirrors.ovh.net/debian/dists/squeeze/main/binary-amd64/Packages.gz  404  Not Found [IP: 2001:41d0:202:100:213:32:5:7 80]

W: Failed to fetch http://security.debian.org/dists/squeeze/updates/main/source/Sources.gz  404  Not Found [IP: 2001:a78:5:1:216:35ff:fe7f:6ceb 80]

W: Failed to fetch http://security.debian.org/dists/squeeze/updates/main/binary-amd64/Packages.gz  404  Not Found [IP: 2001:a78:5:1:216:35ff:fe7f:6ceb 80]

E: Some index files failed to download, they have been ignored, or old ones used instead.

I realize I am 3 major versions away from the current, what do I need to do from here to upgrade to Debian Stretch properly based from the errors I get?

  • Could you post the full error messages? – dsstorefile1 Apr 21 at 8:19
  • @dsstorefile added more info – IMB Apr 21 at 8:41
  • 1
    Comment out all the urls in sources.list that are unreachable. – n8te Apr 21 at 9:18
  • @n8te well it appears the (2) only URLs are both unreachable – IMB Apr 21 at 10:47

I'd just jump straight to wheezy, but if you want to run updates for squeeze beforehand you can change your sources.list to point to archive.debian.org.

deb http://archive.debian.org/debian-security squeeze/updates main
deb http://archive.debian.org/debian squeeze main
deb http://archive.debian.org/debian squeeze-lts main
deb http://archive.debian.org/debian squeeze-proposed-updates main
  • I did that and now I get: W: GPG error: http://archive.debian.org squeeze/updates Release: The following signatures were invalid: KEYEXPIRED 1520281423 W: GPG error: http://archive.debian.org squeeze Release: The following signatures were invalid: KEYEXPIRED 1520281423 KEYEXPIRED 1501892461 E: Release file expired, ignoring http://archive.debian.org/debian/dists/squeeze-lts/Release (invalid since 766d 20h 12min 50s) – IMB Apr 21 at 10:49
  • You can ignore the warnings. I don't remember getting the message about squeeze-lts though, so you might want to comment that one out. – dsstorefile1 Apr 21 at 10:52
  • Ok now when I try apt-get upgrade it says 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. – IMB Apr 21 at 10:59
  • I tried again.. now this is what I get WARNING: The following packages cannot be authenticated! base-files tzdata – IMB Apr 21 at 11:00
  • If squeeze is up-to-date then you can move to wheezy. – dsstorefile1 Apr 21 at 11:03

As others have said you need to go Squeeze -> Wheezy -> Jessie -> Stretch.

To solve your package signing issues I'd manually install the debian-keyring from the release you're upgrading too first (Downloadable via packages.debian.org). (dpkg -i debian-keyring_version.deb to install)

Then follow the instructions in the release notes for each release:

I think this way you can upgrade.

First upgrade Debian Squeeze To Wheezy.

How To Upgrade Debian Squeeze To Wheezy

Then upgrade Debian Wheezy to Jessie.

How to upgrade Debian Wheezy to Jessie safely

Finally upgrade Debian Jessie to 9 Stretch.

How to Upgrade Debian 8 (Jessie) to 9 (Stretch) safely

  • 1
    Sorry but I'm using command line only, no GUI – IMB Apr 21 at 8:17
  • Try this command --> sudo apt-get dist-upgrade – Eranda Peiris Apr 21 at 8:24
  • I got this 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded – IMB Apr 21 at 8:40
  • I would advise you to update from squeeze to wheezy first and then from wheezy to jessie finally jessie to Stretch. – Eranda Peiris Apr 21 at 8:42
  • 1
    Well yeah but I get those errors in the description – IMB Apr 21 at 8:50

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.