Actually I am using fish these days and I completely switched from bash to fish (with chsh & terminal startup command) but the matter is when I enter a wrong command e.g. qwerty its output is: bash: qwerty: command not found... since I switched to fish completely Why bash say that (instead of fish e.g. fish: qwerty: command not found...)?

Also searched for it but no luck!

  • What version of fish do you use? I reported this 3 years ago: github.com/fish-shell/fish-shell/issues/1918 – glenn jackman Apr 22 at 18:38
  • Oops! I didn't think so but restart the session solved the problem and now I have 'fish:' instead of 'bash:'! fish version: 2.6.0. I am sorry guys! :) – Cy8099 Apr 22 at 19:09
  • 1
    @Cy8099 Welcome to SuperUser. The right way to show you’ve solved your own Question is to post your solution as an Answer, and then check the check-mark outline next to your own Answer to show you’ve accepted it as the right Answer. – Spiff Apr 22 at 19:27
  • Oh! I didn't no :0 sorry about that! Now I think I did it in a right way (but when I want to check my answer as a correct one it says: 'you can accept your own answer in 2 days') thank you anyway @Spiff – Cy8099 Apr 22 at 20:26
up vote 1 down vote accepted

I just restart the current session (by logging out and then back in) and that's all! issue has been sloved!

Thanks for your comments guys :)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.