1

I'm currently installing an OpenVPN clent+server to have a remote acces to my server files. I've set up both side, generated the keys and now my client can be connected (with the green icon). Once i'm in the VPN network, I can't do anything. It's impossible for me to ping 10.8.0.1 (the VPN server adress) or to connect to my remote files. The strangest things here is that everything was working last week, i don't know what i've broke haha. My server runs under windows 2012r2 and all my clients under windows 10. Here is my configuration file : -client:

client
dev tun
;dev-node MyTap
;proto tcp
proto udp
remote WWW.XXX.YYY.ZZZ 27234 #(IPv4 adress)
;remote 192.168.1.10 27234
;remote-random
resolv-retry infinite
nobind
;user nobody
;group nobody
persist-key
persist-tun
;http-proxy-retry # retry on connection failures
;http-proxy [proxy server] [proxy port #]
;mute-replay-warnings
ca      ca.crt
cert    client1.crt
key     client1.key
remote-cert-tls server
cipher AES-256-CBC
verb 6
;mute 20

and for the server side:

;local 192.168.1.10
port 27234
;proto tcp
proto udp
;dev tap
dev tun
;dev-node MyTap
ca      "C:\\Program Files\\OpenVPN\\easy-rsa\\keys\\ca.crt"
cert    "C:\\Program Files\\OpenVPN\\easy-rsa\\keys\\server.crt"
key     "C:\\Program Files\\OpenVPN\\easy-rsa\\keys\\server.key" 
dh      "C:\\Program Files\\OpenVPN\\easy-rsa\\keys\\dh4096.pem"
crl-verify "C:\\Program Files\\OpenVPN\\easy-rsa\\keys\\crl.pem"
topology subnet
server 10.8.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
;server-bridge 10.8.0.4 255.255.255.0 10.8.0.50 10.8.0.100
;server-bridge
;push "route 10.8.0.0 255.255.255.0"
;push "route 192.168.20.0 255.255.255.0"
;client-config-dir ccd
;route 192.168.40.128 255.255.255.248
;client-config-dir ccd
;route 10.9.0.0 255.255.255.252
;learn-address ./script
;push "redirect-gateway def1 bypass-dhcp"
;push "dhcp-option DNS 208.67.222.222"
;push "dhcp-option DNS 208.67.220.220"
;client-to-client
;duplicate-cn
keepalive 10 120
;tls-auth ta.key 0 # This file is secret
cipher AES-256-CBC
;compress lz4-v2
;push "compress lz4-v2"
;comp-lzo
;max-clients 100
;user nobody
;group nobody
persist-key
persist-tun
status openvpn-status.log
;log         openvpn.log
;log-append  openvpn.log
verb 6
;mute 20
explicit-exit-notify 1

Do you know why can't I access my files ? When i ping i don't have any respond, but wireshark show me that the server get the ping, but don't answer to it. Any help is welcome, have a good day. SeedBarrett

0

ok after 3 longs day i have finaly discovered the truth : my server's firewall blocked my port on the output. That's why i could be connected but i hadn't any ping or anything. I hope it will help someone else. TRIPLE CHECK YOUR FIREWALL (double checking wasn't enought for me haha)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.