0

I'm trying to get sound to work in Virtual Box. At one point in time, it worked. After a long time not using virtual machine, now it doesn't (I know I've switched virtualbox versions). Host OS = Windows 7, guest OS = linux/windows. Sounds works just fine in Host OS. On the guest OS I KNOW that worked once upon a time the settings are:

Windows Direct Sound

ICH AC97

Because I haven't touched those settings and they've worked in the past, those settings must be right. I am convinced its a virtualbox issue, but not sure how.

I know for a fact the version I used would have to have been greater than 4.2. I'm thinking 4.3 is the one. I've tried 4.3, 5.1 and 5.2, and the latest test build 5.2.11. I've tried installing fresh guest OS windows 7, tried Intel HD audio, the drivers installed by default. I've tried ICH AC97, downloaded and installed realteks AC97 drivers. I've tried reinstalling the audio drivers on the host OS.

I've also tried the things in VirtualBox Windows 7 Host, XP Guest cannot play audio

Here is my VBox.log: https://pastebin.com/LD6GydBJ

Here is my VBoxHardening.log: https://pastebin.com/8zmRvF5k

Something interesting from the logs which may be the culprit: DSound: Creating capture buffer failed with E_FAIL

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.