0

i try to boot puppy linux from an usb stick.

it works when there is no hdd in the notebooks ide (ata) hdd slot.

but when i insert a hard drive, it tries to boot from this one.

reconfiguring the bios boot order does not help as the computer seems to identify both, usb stick and ide harddrive, as hard disks and i can only prioritize some "hard disk". external drive or cd-rom on first place do not change anything.

i also tried to put the ide harddrive into secondary mode using a jumper but it didn't help. the notebook still tries to boot from this one.

any suggestions? thanks

edit: notebook is a siemens amilo M1425.

3
  • (Please advise make and model of notebook). Try finding a new BIOS and flashing that onto The notebook. Alternatively you have a fair chance of being able to install Linux on the HDD using another PC and inserting it into the laptop if the goal is to run Linux on it. You also might be able to zero the first sector of the drive - to remove the MBR - so the computer will skip to the next bootable disk. – davidgo Apr 24 '18 at 19:15
  • thanks! i will try to get a new bios. using a different pc is complicated because ata hdds are so outdated – ullices Apr 24 '18 at 19:20
  • @ullices - You could try an ATA USB dock. If you haven't got one, they're not expensive. You can then plug in the hard drive after you have booted your pen-drive, or use it on another PC. – AFH Apr 24 '18 at 20:17
0

I know a lot of time has passed but I want you to know that we finally solved this problem by booting from an external CD-drive (in fact from a smartphone that was emulating a CD-drive) Anyway, thanks for your suggestions. Ullika

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.