1

Problem:

I use Acer Aspire TimelineX 5830TG laptop with Windows 7 Home Premium(64-bit). I have problems with connecting to other WiFi than my home WiFi network. Windows "sees" other networks and tries to connect to them, but I cannot open any webpage. The problem is not new, but I didn't need to use WiFi outside home before now.

What I tried:

  • Using USB WiFi adapter(D-Link Wireless N150 High-Gain USB Adapter Ver.: A1). It "sees" all networks around, but fails to actually connect. I have also tried other USB adapters before, they haven't worked.
  • Using tethering from my smarthphone through Bluetooth(Laptop doesn't see phone/network at all) and USB(the same)
  • Things from https://support.microsoft.com/en-us/help/10741/windows-10-fix-network-connection-issues from first to "Temporarily turn off firewalls"
  • Reinstalling Network adapter's drivers(though I'm not sure if I've done everything correctly)

More hardware information:

  • The standard build-in network adapter is "Atheros AR5B97 Wireless Network Adapter #2"

  • Other network adapters visible in "Network Connections" are:

    • "Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20)"
    • "Microsoft Virtual WiFi Miniport Adapter"
    • "VirtualBox Host-Only Ethernet Adapter"
    • "VirtualBox Host-Only Ethernet Adapter #2"
  • Several more network adapters are visible in Device Menager

If you need any more informaton, please ask. Any help will be apreciated.

  • 1
    What are your adapter settings? IP =auto? DNS =auto? Have you tried updating the drivers for the wireless adapter? Atheros chipsets are usually very reliable. – Tim_Stewart Apr 25 '18 at 16:01
  • I looked into settings of "Atheros" and there are "Use the following IP address" and "Use the following DNS server address" chosen. I tried to change both to "obtain automatically" but it didn't work(with home network and with smartphone hot-spot). – user351437 Apr 25 '18 at 16:46
  • If your adapter settings are statically set as opposed to dynamic (auto). You are going to get unexpected results trying to connect to other access points. It should be set to automatic. Try updating the drivers, download them first then under device manager uninstall the adapter, if it prompts you to uninstall the drivers choose yes. Reboot Then use the drivers you downloaded to reinstall. Let me know if that makes a difference. – Tim_Stewart Apr 25 '18 at 16:51
  • I uninstalled and installed the adapter again. After trying to connect to home network there is a message that "connection was not successful"*, but "there is a limited connectivity with the network"*. The internet does not work(Chrome shows: "DNS_PROBE_FINISHED_NO_INTERNET"). The default settings are "Get IP/DNS address automaticaly". * - my translation, my Windows is not in English. – user351437 Apr 25 '18 at 17:24
  • Start -> cmd then enter -> ipconfig /all. Do you have a IP address for your adapter? Is it showing a DNS address that's the same as your default gateway? Also does your phone connect ok when you connect wirelessly to the access point? – Tim_Stewart Apr 25 '18 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.