0

Alright, I've got a DLL that I need to register onto Windows Server 2012 R2. The DLL itself was custom made for us and I don't know the background, but we've never had an issue like this.

Whenever I try to register the DLL, I get the error message "The module was loaded but the call to DllRegisterServer failed with error code 0x80004005". All the solutions say that running CMD as Administrator solves the problem. I've tried that on the Domain Administrator account, and the local Administrator account on that server, and I've even tried registering the DLL with PowerShell (as admin).

We've tried disabling UAC, that didn't help. I closed the only AV they have on the server, that didn't resolve it either.

  • In recent versions of Windows, "running as administrator" doesn't mean simply running under an account with administrative privileges; you must right-click on the Command Prompt icon and select "Run As Administrator" from the menu. You will be prompted for credentials; supply correct ones. – Jeff Zeitlin Apr 25 '18 at 16:43
  • Yep, that's what I've been doing. – Daedalus Apr 25 '18 at 16:45
  • OK, wasn't clear from your posting. – Jeff Zeitlin Apr 25 '18 at 16:58
  • Have you tried both c:\Windows\System32\regsvr32 szYourDLLName.DLL and c:\Windows\SysWOW64\regsvr32 szYourDLLName.DLL ??? Please feed back @Fabby after trying as it might be a 64-bit DLL being called by the 32 bit regsvr32version or vice versa (hard to tell with the information you gave) – Fabby Apr 25 '18 at 18:27

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.