0

Problem:

I am unable to connect to/from Windows 7, Mac PCs and Raspberry PIs (Samba Shares on Raspbian) connected via LAN (via 2 dumb Netgear switches). I can ping in both directions without problems. FTP also works. It's just accessing shares in both direction. I can even connect from my PC to another e.g. Win7 PC but it shows no shares. Connecting to hidden share C$ also doesn't work.

Background:

I have multiple networks: USB-LTE (primary internet connection), LAN cable (has internet connectivity but I don't use it), VPN (Cisco to work) and 2x Hyper-V Virtual adapters for Hyper-V VMs (usually not running). I use "route add/delete" to set metrics of each connection to set priority, otherwise Windows sets the default metric of my LAN cable as higher priority even though my LTE connection is 20x faster to the internet. Windows Firewall is deactivated and I use NetLimiter for blocking connections. This setup has worked in Windows 7 for many years and with Windows 10 everything worked until about 1 year ago (I don't remember exactly when, nor did I pay attention to which updates might have caused it). I have tried numerous instructions from various forums and none of the solutions has provided any help. The latest recommended solution to similar issues was to ensure that Peer Networking Grouping service is enabled. Currently the service is set to Manual and won't start, giving the error "Error 1068: The dependency service or group failed to start." - the dependency being Peer Networking Identity Manager service, which also won't start due to "Access Denied". I am unable to determine why, in EventViewer it just says error 5 with no other details.

Further research suggested that I should delete "C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking\idstore.sst" which I did, as well as all other idstore.* files in this directory. Note: I could not access ServiceProfiles or any directory thereafter without confirming a warning to allow access, since I did not already have permission. After deleting all idstore.* files and rebooting, I still have no network connectivity and I am still unable to start both Peer Networking services.

Other ideas I have tried:

  • enabled the Windows Feature SMB 1.0/CIFS Client as well as SMB Direct

  • setting Peer Networking Identity Manager "Log On" value to Local System account, apply, then set back to "Local Service" (with empty password)

  • sfc /scannow

  • dism /online /cleanup-image /scanhealth

Network and Sharing Center:

  • HomeGroup > Create a homegroup:

enter image description here

Network and Sharing Center toggles (tried both settings in all cases):

  • Private: Turn on/off network discovery

  • Private: Turn on/off file and printer sharing

  • Private: Allow Windows to manage homegroup connections / Use user accounts and passwords to connect to other computers

  • Guest/Public: Turn on/off network discovery

  • Guest/Public: Turn on/off file and printer sharing

  • All Networks: Turn on/off sharing so anyone with network access can read and write files in the Public Folders

  • All Networks: Use 128-bit encryption/Enable file sharing for devices that use 40- or 56-bit encryption

  • All Networks: Turn on/off password protected sharing

  • Start the HomeGroup troubleshooter > Troubleshoot network problems > "Troubleshooting couldn't identify the problem"

  • Start the HomeGroup troubleshooter > Skip This Step > "Troubleshooting couldn't identify the problem"

  • Enable Homegroup Listener and Homegroup Provider services

EDIT:

  • disabled all NetLimiter 4 features and disabled system service
  • Provide your Samba configuration, do yourself a favor, make sure you have configured it to support SMBv2+. Additionally, you can change the metric of your Network and Wireless (Network) adapters. – Ramhound Apr 26 '18 at 12:45
  • Sorry I should have specified, it's not just Samba Shares, Windows 7 and OSX systems also can't see my shares and I can't see their shares. – glenneroo Apr 26 '18 at 12:53
  • Sounds like a firewall configuration. Remove NetLimiter out of the equation, and instead of disabling Windows Firewall, configure it to explicitly allow the traffic on the appropriate ports. If you have a service, that fails to start because of a dependency, then you have to determine the reason the dependency cannot be started. You need to determine the reason these services cannot be started. – Ramhound Apr 26 '18 at 15:24
  • @Ramhound I disabled NetLimiter and Windows Defender Firewall is running but I have all profiles disabled. – glenneroo May 1 '18 at 22:03
0

You want to make sure the samba server is running SMB v3 or higher. This allows modern versions of Windows to access the server. Homegroup is not going to solve your problem.

  • I added more information to my problem: it's not just samba shares, it's also Windows and OSX - and it's in both directions! – glenneroo Apr 26 '18 at 12:59
0

The Reason

I think you are hitting the newest Microsoft "great" move to remove Computer Browser service. (I think it was around for 25 years or so). The main reason is to stop using NetBIOS for browsing. The replacement is called WSD Provider.

The service is broken as of Windows 10 Creators 1703. If the Win10 1703 is the Master Browser only that computer has Computer Browsing. If a non-1703 is the Master Browser all the non-1703 have Computer Browsing. That is the reason why it sometimes appears to work and sometimes not. Rebooting forces a change in the Master Browser on the network.

The workaround

You have to set one computer to be the Master Browser. Maybe you can set your SAMBA to be the master browser for all non-1703 computers.

How to identify the Master Browser?

Issue the following command: nbtstat -a YOUR_COMPUTERNAME

The computer that is Master Browser will have __MSBROWSE__ in the *Name column** e.g. ..__MSBROWSE__.<01> GROUP Registered (I'm on AD so it is little bit different but you get the idea.)

To set a computer to be a Master Browser you have to change the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters and change the value of MaintainServerList from Auto to Yes.

Additional to that if you are missing a String value IsDomainMaster then create it and set it to True.

On the other hand, if you are sure that you don't want your PC to take over the Master Browser role set the value of MaintainServerList from Auto to No (you may want to set it on all computers on your workgroup/network).

As for the Win10 1703 and above you may want to start the Computer Browser service and set it to Automatic.

Important to note

This is only temporary fix! Microsoft apparently decided to remove the Computer Browser service completely at some future point of time.

Edit Due to the comment - for better understanding

The win10 1703 and above update must be a client not a Master browser (must only have the Computer Browser service started and set to automatic) . The Master browser must be either pre-1703 win10 machine, win8, win7, samba, etc. The other machines will check for the Master browser and will see it if set this way. The post-1703 win10 machine will also see it but it must be a client only not a Master browser!

  • Running this showed 5 adapters all with "Host not found.". Is that a problem? – glenneroo May 7 '18 at 20:18
  • I changed MaintainServerList and added IsDomainMaster and rebooted. Still can't see any shares when I connect to any devices (tested: Win7, PI and USB connected to Tomato-flashed router). – glenneroo May 7 '18 at 21:37
  • Computer Browser service is also running. – glenneroo May 7 '18 at 21:38
  • @glenneroo is your win10 pre-1703 or later? – tukan May 8 '18 at 9:35
  • Version 10.0.16299.371 (Registry ReleaseId: 1709) – glenneroo May 8 '18 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.