1

I've booted with the net.ifnames=0 in GRUB_CMDLINE_LINUX_DEFAULT so
It does fix the name of the internal adapter

wlp2s0 >> wlan0

But I can't find a solution to my external adapter which is AWUS036H

when I run iwconfig I get

kira@dark:~$ iwconfig
eth0      no wireless extensions.

wlan0     IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

lo        no wireless extensions.

wlx983f9f25df10  IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short  long limit:2   RTS thr:off   Fragment thr:off
          Power Management:off

This extra weird name wlx983f9f25df10 is my problem;

or even airmon-ng

kira@dark:~$ sudo airmon-ng

PHY     Interface       Driver      Chipset

phy0    wlan0           iwlwifi     Intel Corporation Wireless 3160 (rev 83)
phy1    wlx983f9f25df10 rt2800usb   Ralink Technology, Corp. RT2870/RT3070

I use my external card a lot in the terminal, I don't want to write this whole name or copy/paste it every time I want to call a command. Can't I just change it to a simpler name like wlan1?

On Ubuntu 17.04, I tried editing in rules.d and udev according to some answers but It
doesn't work and I may be editing in a wrong way cause I don't really know what to edit/remove or change there for this specific adapter, Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.