2

I was wanting to connect my tablet to my laptop which is using PDAnet to connect to the internet through my phone. The phone is connected via USB. I tried the "WiFi Share" option through PDAnet but it directed me to the Windows Hotspot settings which doesn't allow me to select the USB connection.

I changed the sharing settings of the connection to allow other people to use it.

Is there any way to get Windows to recognize this connection and share it?

2
  • Not a direct answer but why not simply connect the tablet to the phone's wifi hotspot? Apr 27 '18 at 3:09
  • I used all of my allotted hotspot and USB tethering is much faster. Also, the PDAnet hotspot settings (WiFi Direct) change every time you start the service. If I use FoxFi it still counts against my hotspot data that I get from my service provider. It seems easier to just plug the phone into the USB and create a hotspot with my laptop. Apr 28 '18 at 3:32
0

So here's what you do:

  1. turn on actual mobile hotspot (the one on your phone)
  2. connect PC to it
  3. bottom right of Windows is the notifications button, click it and hit mobile hotspot, it won't be greyed out anymore.
  4. leave the PC hotspot on while turning off the phone's mobile hotspot
  5. teather phone to PC (PDAnet, foxfi, whatever)
  6. bask in glorious Wi-Fi

This used to be about 10 steps longer but I've simplified it.  I'll update if I find an easier way.

0

Windows 10 WiFi Hotspot fix after update.

Microsoft Windows 10 Pro Build 17134

Mobile hotspot button is now greyed out, cannot switch it on again in settings either:

ms-settings:network-mobilehotspot

We can't set up mobile hotspot because your PC doesn't have an
Ethernet, Wi-Fi, or cellular data connection.

(Not true Microsoft!)

Wi-Fi button must be on (bottom right in notifications panel), quote Scott & Steven Madden:

>turn on actual mobile hotspot (the one on your phone)
>connect PC to it
>bottom right of Windows is the notifications button, click it and hit Mobile hotspot,
>it won't be greyed out anymore.
>leave the PC hotspot on while turning off the phone's mobile hotspot
>teather phone to PC (PDAnet, foxfi, whatever)

e.g use USB cable, then Right click PdaNet icon > Connect

Control Panel\All Control Panel Items\Network Connections

Right click > PdaNet Broadband > Properties > Sharing > Internet Connection Sharing > Check Allow

Change "Home Networking Connection" dropdown manually to Local Area Connection* 4

OK > Yes

Adapter number is likely to change as Microsoft Virtual Wifi adapter only appears when Hotspot is on. So this step may have to be done twice (uncheck > OK, Check > OK) if WiFi Hotspot is connected but there is no IP / Internet Data passing through to your connected device.

Not the answer you're looking for? Browse other questions tagged or ask your own question.