0

I install Ubuntu Server 16.04 on a SATA3 - 750 GB, but I hadn't success in the first try. After booting with the USB, Grub2's console was loaded and I had to load manually the Ubuntu. (I also have another HD with Xubuntu installed)

To load the Ubuntu Server I did:

grub> set root=(hd1,msdos5)
grub> linux /install/vmlinuz
grub> initrd /install/initrd.gz
grub> boot

It worked and I was able to install the Ubuntu, but after select the option at grub I got frozen in a black screen with a similar message:

dev/sdb1: mount, files: XXXXXX, blocks XXXXXXX

What I have done to solve the problem:

  • Check for consistency on the HD, no error found.
  • When frozen in black scream, Ctrl+Alt+Del restart the system showing Ubuntu image before closing.
  • I was able to load and use the OS in recovery mode.
  • In recovery I execute all the options of update, check filesystem and others that work fine.
  • The grub master was installed in my Xubuntu HD, so the config files for grub are saved there.

Some observations that I found when searching for solutions:

  • I read that sdb1 can be the cause for not loading the OS.

  • That I should specify the location of the root filesystem when loading the OS with grub, otherwise it could get kernel panic. The command should be:

    grub> linux /install/vmlinuz root=/dev/sda1

I believe the problem is simple, the OS is not able to find the right file to start.

I need ideas to solve this problem.

Thanks in advance!

UPDATE - update-grub command (output)

Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-4.13.0-37-generic
Found initrd image: /boot/initrd.img-4.13.0-37-generic
Found linux image: /boot/vmlinuz-4.13.0-36-generic
Found initrd image: /boot/initrd.img-4.13.0-36-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found Ubuntu 16.04.4 LTS (16.04) on /dev/sdb1
done
  • If you can boot Xubuntu then, with the external drive connected, open Terminal and do sudo update-grub. Hopefully it's all you need. It is not if you installed in a different mode, of course. BTW, UEFI or BIOS (Legacy)? – user772515 Apr 28 '18 at 3:09
  • @MichaelBay, sorry for answering late, and thank you for the help. The command update-grub didn't work. I will update my question with the out come from the command. And about the different mode, UEFI or BIOS, I don't know what you mean. If you give an explanation or something that I can check, I will answer that. – Pedro Gabriel Lima Apr 30 '18 at 16:16
  • Almost any PC since almost a decade ago has UEFI, not BIOS. But also most of the UEFI PCs come with a compatibly mode ("BIOS"/Legacy/CSM) for older OSes that don't support UEFI. For installing an OS, and especially with dual or multi boot, not knowing about this modes and requirements is not an option. (...) – user772515 Apr 30 '18 at 16:35
  • 1
    Anything you can do with Ubuntu Server can be done with Xubuntu. So, perhaps you don't need a separated Ubuntu Server? – user772515 Apr 30 '18 at 17:03
  • 1
    Keep it simple. You already have a working Xubuntu. If you want to practice commands, open the Terminal, same thing. If you want to use server features install what's needed. – user772515 Apr 30 '18 at 17:16
0

This sort of issue is unfortunately very difficult to debug (even locally, but even more so across the web). In general you can try booting a live USB stick (as in, all the way to the OS, not just to the GRUB prompt) and checking which partition is marked as bootable. You'll then need to reconfigure GRUB to point to that partition. Once that's done booting should work.

  • Assuming Xubuntu (the one that boots) and Ubuntu Server were installed in the same, booting Xubuntu and running update-grub should be enough, shouldn't it? – user772515 Apr 30 '18 at 16:53
  • After update-grub check whether your /boot/grub/grub.cfg contains the entries you expect. If it does then you should be golden. If not you may want to include it in the question. – l0b0 Apr 30 '18 at 20:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.