10

I was fooling around a bit with the Linux/Bash subsystem for Win10.

But then I decided to stay with Cygwin for now. So I uninstalled it - or thought I did.

Now I've installed Cygwin and put its bin directory first in the PATH.

In cmd.exe , when I type bash , it will start the Cygwin's Bash.

But when I do Win+R and type bash, I still get the prompt:

Windows Subsystem for Linux has no installed distributions.
…bla-bla-bla…

How do I get rid of the Linux/Bash subsystem entirely, so it will instead pick up Cygwin's Bash from the PATH?

24

If your OS has been upgraded to the Fall Creators Update, you should be able to issue the command wslconfig.

You could of course try uninstalling first by using the command lxrun /uninstall /full.

If its still there, you can try unregistering the distro:

  • First you need to know which distro is installed by using

    wslconfig /l
    
  • From the list choose the distro (e.g. Ubuntu) you want to uninstall and type the command

    wslconfig /u Ubuntu
    
  • 2
    lxrun was deprecated with the release of 1709, and wslconfig doesn’t exist before it, this could be a decent answer if it was improved to be specific. Author was using 1703 (or earlier) by the way. – Ramhound Jul 10 '18 at 3:15
  • Works as of Apr 2019. – Desik Apr 5 at 16:12
  • 4
    I had to do a wslconfig /u Legacy to remove the Ubuntu that was shipped with Windows. – Kees C. Bakker May 6 at 7:21
6

In order to disable WSL, one has to go back into

Control Panel -> programs-features -> turn on/off Windows features and deselect Windows Subsystem for Linux, and Save.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.