0

I have a process (more specifically, multiple processes with the exact same name) running that I cannot kill no matter what I try. The reason I am asking this question here even though I know it's been asked before is because I've tried every answer that I can find to no avail.

Obviously opening task manager and trying to end the process does not work, so here are other things I have tried:

  • Locating the folder which the process is running from. Access Denied.
  • Going into the properties of the folder, going under securities tab, and tried to change the permissions. Doing this from the admin account, still access is denied.
  • Downloading Process Hacker. Seems like this app would do exactly what I need, but unfortunately the program terminates as soon as the window opens every single time running it.
  • Using the program LockHunter to try and either delete or access the folder which is running the processes, as this is what the software is supposed to be able to do, however it just tells me AGAIN, the bain of my existence, Access Denied.

I'm just completely at a loss at this point. Any help with killing these processes or getting this folder off of my computer would be incredibly appreciated.

2
  • What specific processes are you dealing with? Are you sure they're not part of the operating system? Certain privileged OS processes cannot by killed by the user anymore as of Windows Vista-ish (or at least as of Windows 7). – allquixotic Apr 28 '18 at 5:45
  • Sounds like your PC has an infection or malware installed. – Moab Apr 28 '18 at 12:24
0

General answer to the question: If a file defeats all attempts in being terminated while the OS is online, the solution is kill it when the OS is offline. There are two ways:

  1. A Sysinternals utility called MoveFiles can order Windows to kill a file during kernel initialization stage, when almost no process is open.
  2. Windows Recovery Environment (Windows RE) or a Windows installation disc can both be used to boot the computer and open a Command Prompt. This Command Prompt can then be used to delete the file.

Specific answer for HarroweD: The description of your experience has ominous hints that point to serious malware infection (possibly a rootkit). The fact of Process Hacker disappearing when you try to start it, is specifically concerning. (Malware often do that to avoid death.) I suggest you do either of the following:

  • Have an expert take a look at your computer
  • Create a new user account and log in with it. Then, install and update a good antivirus software to cleanse your infection. (Delete your old user account after rescuing your documents and data.) If that failed, nuke your current installation of Windows.

I hope you have backup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.