0

I am trying to enable copy/paste between a Kali Linux virtualbox machine and a Windows host machine. First from the virtual machine advanced settings, I enabled bidirectional choice at both shared clipboard and drag and drop. Then I went to the virtualbox Devices-> Insert Guest Additions CD image. Then a CD icon appeared in the desktop. When I try to open the CD icon and click the Run Software button at the top right corner, I get an error saying Unable to locate the program. See the screen shot below. Can you help me how to enable copy/paste between the two machines?

enter image description here

Update: I followed the first comment's instructions. I got this problem: enter image description here

1
  • @None Use apt-get update; apt-get upgrade.
    – Biswapriyo
    Apr 29 '18 at 15:25
0

If you see the cd icon on your desktop it means the guest additions are on.Instead of copying and pasting files and folders between host , guest and vice versa you can mount a sharing folder in which you can add everything you want to be shared between the two OS's.As far as i know this is one of the advantages the guest additions offer.Another one is so your virtual machine screen resolution fits perfectly the monitor size without sidebars.All of the above while VTx is enabled.

1
  • Welcome to Super User! This doesn't really answer the question OP asked, can you suggest how they might enable copy and paste instead?
    – bertieb
    Jun 21 '18 at 23:37
0

You might want to check whether you have the mentioned entry in your sources.list located under /etc/apt/sources.list.

You should see an entry like this: deb http://http.kali.org/kali kali-rolling main non-free contrib
For more information read here.

Make sure that you have the latest dist upgrades by running (sudo) apt-get dist-upgrade. For this action you might want to deactivate your antivirus on the host machine. You will be prompted with some questions you definetly should read carefully and decide wheter enable or disable this feature. After installation completed you restart the VM.

Alternatively run (sudo) apt-get update && apt-get install linux-headers-$(uname -r).
If header installation failed you might want to check manually for applicable headers and install them by running apt-cache search linux-headers to list all available headers and install the desired one with apt-get install linux-headers-<kernel-release>.

Then try again running (sudo) apt-get install -y virtualbox-guest-x11.
Note: Like @dsstorefile alreade mentioned ther is no dash between virtual and box!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.