52

I installed Ubuntu 18.04 LTS inside VirtualBox 5.1.26. I installed guest additions, enabled clipboard sharing and rebooted the guest VM. However, clipboard sharing doesn't work. How can it be fixed?

65

The problem is with the virtualbox-guest-x11 package missing.

Execute the below commands:

sudo apt-get update
sudo apt-get install virtualbox-guest-x11

If it asks you about keeping a file or installing the new one, select the new one.

sudo VBoxClient --clipboard

This should enable clipboard sharing. Make sure that Clipboard Sharing is set to Bidirectional under VM Settings in VirtualBox as seen here:

Clipboard Sharing in VirtualBox

| improve this answer | |
  • 1
    This solution worked for me (Win 10 host + Xubuntu 18) – Alex Apr 3 '19 at 9:54
  • 2
    This solution worked for me (Host: Ubuntu 15.10, guest: Ubuntu 18.10). I needed to run all 3 commands and to say YES for the answer about maintain or replace a file. Thanks – user2342558 May 9 '19 at 8:39
  • 3
    After I use aptitude to install virtualbox-guest-x11, it freezes my ubuntu 18.04 64bits. Now I need to reinstall ubuntu 18.04. – sam May 13 '19 at 7:56
  • 1
    This isn't working on my setup: Both host and guest are running Xubuntu 18.04, VirtualBox version is 6.1.2 r135662 (Qt5.9.5). I have installed the packages and the binary from the GuestAdditions CD image, rebooted, run sudo VBoxClient --clipboard but still no clipboard sharing. – FriendFX Feb 11 at 2:19
  • 1
    @sam Try to disable 3D acceleration – Hannes Schneidermayer Feb 24 at 23:45
30

The problem is old version of VirtualBox that has the old guest additions version. Updating VirtualBox to 5.2.8 helps in this case. After updating VirtualBox, the guest additions must be updated in the following way:

  • Do sudo apt install linux-headers-$(uname -r) build-essential dkms if not done already.
  • Select Devices -> Insert Guest Additions CD Image... from VirtualBox VM menu
  • Follow the instructions
  • Eject the CD from Ubuntu after installation is done
  • Reboot the Ubuntu guest VM
  • Select Devices -> Shared Clipboard -> Bidirectional from VirtualBox VM menu to ensure clipboard sharing is enabled

Now shared clipboard should work.

| improve this answer | |
2

NOTE: The following solution worked with the following setup:

  • Windows 10 (v. 1909)
  • Virtualbox 6.01
  • Ubuntu 18.04 (with all software updates installed)

I honestly would try THIS solution before any of the other solution, because as of Dec 15th 2019, this solution is the only one that didn't completely fail. I had the same problem that sam had (the 3rd comment in juhist's answer). After following juhist's answer my ubuntu virtualbox was completely frozen after rebooting (keyboard and mouse wouldn't work after ubuntu logged in). Luckily I made a snapshot before I executed the solution, so I rolled it back and did this instead:

BEFORE YOU BEGIN:

Shut Down your Ubuntu Virtualbox, and make a Snapshot! That way if anything goes wrong, you can restore your working image.

STEP 1:

After making a snapshot, start your Ubuntu virtualbox back up, open up the terminal, and execute the following:

sudo apt update
sudo apt install build-essential dkms linux-headers-$(uname -r)

FYI: $(uname -r) prints the running Kernel version.

STEP 2:

From the virtual machine menu, click Devices -> “Insert Guest Additions CD Image”

This should mount a virtual CD/DVD drive inside the Ubuntu guest machine. When that happens, you should get a prompt to run the software. Click Run to begin the installation.

If you get an error saying the guest system has no CD-ROM, stop the virtual machine, open the virtual machine settings and from the “Storage” tab, add a new CD-ROM device to the machine by clicking on the plus sign (Adds optical device). Once done reboot the virtual machine.

STEP 3:

Restart the guest machine and you’re set.

Still Have problems? I got most of my instructions from the following two pages. These pages have additional steps to try if the above didn't work for you.

| improve this answer | |
  • Did you try my answer or Swapnil Goad's answer? sam's comment is not a comment to my answer, and I see your answer is very similar to mine. – juhist Dec 16 '19 at 9:55
  • I tried Swapnil's. It didn't work. For some reason, when I saw your answer below the most voted on answer, I just saw you mention "Updating VirtualBox to 5.2.8" and since I was using 6.01, I didn't want to try yet another "answer" that may have been outdated. I had tried for two hours at that point until I came across the pages I posted in my answer. I'll upvote yours now that I see it's basically the same thing. That said...I do like my formatting better ;-) – Doomd Dec 16 '19 at 10:11
  • This isn't working on my setup: Both host and guest are running Xubuntu 18.04, VirtualBox version is 6.1.2 r135662 (Qt5.9.5). I have installed the packages and the binary from the GuestAdditions CD image, rebooted, but no clipboard sharing. – FriendFX Feb 11 at 2:18
  • Had to downgrade to 6.1.2, do this procedure as well as unix.stackexchange.com/a/349763/145930 to make it work – Barmaley Apr 2 at 1:13
2

Clipboard functionality in version 6.1.4 of GuestAdditions is bugged and won't work.

Download and use the different one - for me version 6.1.2 worked fine.

| improve this answer | |
  • 1
    Why is it bugged and won't it work? – MMM Mar 23 at 14:14
  • @MMM if you want to investigate the cause, you can check ticket #19336 related to this issue – komidawi Mar 23 at 19:15
  • This is the only solution that worked, downgrading to 6.1.2 .. thanks! – hesham_EE Apr 7 at 3:38
  • do I have to downgrade the whole of virtualbox or is is OK to install just the old guest additions? – Andy Apr 7 at 7:49
  • @Andy I used latest VirtualBox and old guest additions and it worked fine – komidawi Apr 8 at 9:26
2

I can confirm the answer from Komidawi.

If you have GuestAdditions version 6.1.4. It just won't work. You'll have to either use version 6.1.2 or download the latest test build (6.1.5)

Install, restart, and it will work.

| improve this answer | |
0

If it doesn't work after installing Guest Additions, just remove the Virtual Optical Disk from the Virtual Drive.

Go to VM. Settings > Storage > Click on the disk icon (next to a file with the name ending in .iso) > Click on the disk shape in the right pane > select the option "Remove Disk From Virtual Drive".

| improve this answer | |
0

Each time you install Guest Additions in version 6.1.4 shared clipboard is broken. There is a trick to problem workaround:

sudo apt-get remove virtualbox-guest-x11
sudo apt-get install virtualbox-guest-x11
sudo /usr/bin/VBoxClient --clipboard
| improve this answer | |
0

Ok I tried everything here and nothing worked, turns out in my VM (Version 6.0.20 r137117) with Ubuntu 20.04 Guest and Windows 10 Host Setup shared clipboard would only ever work if BOTH shared clipboard AND drag&drop is set to bidirectional. if Drag&Drop is disabled it would never work.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.