92

Since Firefox 57 there is no way to disable Ctrl+Q shortcut by plugin on Linux (see this bug). All workarounds I've found are based on setting the global Ctrl+Q shortcut to "steal" it from Firefox. But this will disable this shortcut in every application, and I want to disable this shortcut only in Firefox, without affecting any other app.

Is there a way to disable or catch shortcut only for one application? I'm using Ubuntu with Unity.

4
  • Interesting question, but the answer may depend on the use case. Accidental key presses? Kiosk mode?
    – l0b0
    Commented Apr 29, 2018 at 21:13
  • 5
    @l0b0 Accidental key presses. This is regular PC, nothing fancy.
    – rob006
    Commented Apr 29, 2018 at 21:14
  • In that case, do you have more details? I'm just checking if there is some way the system can be set up to Do What You Want™, such as save the tabs when you quit, to avoid something which I suspect will be a brittle hack.
    – l0b0
    Commented Apr 29, 2018 at 21:46
  • 8
    @l0b0 I want to prevent closing browser by accidental key presses. There is a too many things are changing after closing browser (closing sessions, terminating connections), I would prefer to prevent closing browser than fixing its effects.
    – rob006
    Commented Apr 29, 2018 at 22:30

6 Answers 6

86

In about:config set preferences.

Firefox >= 87

browser.quitShortcut.disabled true

(this setting will take effect with a restart of the browser.)

https://bugzilla.mozilla.org/show_bug.cgi?id=52821

Firefox >= 65

browser.sessionstore.warnOnQuit true
browser.warnOnQuit true

enter image description here

Source

Older Firefox

browser.showQuitWarning true
browser.warnOnQuit true

Tested in all version I've come across 61.0.2-64.0.2 on 64bit Linux (and the 60esr channel on Win10). screenshot

20
  • 11
    And now, as of FF 63.0.3 (64-Bit Ubuntu), ctrl-Q once again quits instantly for me, despite both those options being enabled. It's astonishing what a mess they've made of this simple (mis-)feature. Ah well, maybe it will be working again in v64...
    – Pont
    Commented Nov 23, 2018 at 12:33
  • 6
    I don't see the browser.showQuitWarning on ff quantum 64.0 64bit on linux. browser.warnOnQuit is enabled but does nothing?
    – Bogdan M.
    Commented Jan 19, 2019 at 21:22
  • 7
    This is not working for me in Firefox 66.0.5 in Manjaro Linux. Will have to deal with browser.tabs.warnOnClose;true now. Related: bugzilla.mozilla.org/show_bug.cgi?id=502908#c73
    – aguadopd
    Commented May 19, 2019 at 2:02
  • 5
    Selected answer no longer resolves the issue.
    – Paul
    Commented Jun 6, 2019 at 1:24
  • 9
    After a little more digging, it turns out it's now necessary to enable Preferences > General > Startup > Restore previous session for Warn you when quitting the browser to work.
    – JoL
    Commented Oct 8, 2019 at 17:22
22

tl/dr: assign a global shortcut to Ctrl-Q

In Firefox Quantum, the about:config settings that used to warn against Firefox closures via an accidental Ctrl-Q keypress no longer work.

Workaround: on Arch Linux | XFCE desktop environment (other Linux distros &/or desktops may allow a similar approach):

  • Whiskers menu >> All Settings >> Keyboard >> Application Shortcuts >> Add

  • Add a new "application", null; assign it to the Ctrl-Q keypress

    • Update (comment by @justderb): "Using 'true' instead of 'null' is nice if you don't want the error window to pop up."

Firefox - 'disable' Ctrl-Q

Invocation: here, I pressed Ctrl-Q in Firefox Quantum v. 60.0.1 (64-bit); instead of quitting Firefox, I get this popup,

Firefox - Ctrl-Q 'disabled'

Caveat: this, of course, globally affects all Ctrl-Q keypresses. However, -- per my own preference -- that shortcoming is outweighed by nullifying those accidental Firefox Ctrl-Q closures (after which I must re-login into websites: GitHub; reddit; ...).

Update 1

@crazypyro 's answer also works for me (FF Quantum 63.0 on x86_64 Linux) giving a popup warning if you try to Quit Firefox. That should be probably regarded as the specific answer, with my solution as a more general workaround.

about:config (both of the following set to true):

  • browser.showQuitWarning
  • browser.warnOnQuit

Update 2 [2020-03-01]

For some time in Vim I've encountered the occasional and frustrating issue where the terminal "freezes" and I lose keystroke control of Vim (requiring me to kill/restart Vim).

After some investigating, it turns out the issue is Software Flow Control (XON/XOFF flow control). Ctrl-s freezes the terminal until Ctrl-q is pressed -- which, per my solution presented above, is globally remapped to "dummy application" true.

The workaround to this issue is to add the lines

# enable Ctrl-s and Ctrl-q:
stty -ixon

near the top of your ~/.bashrc, then open a new terminal and start Vim.

Relevant links/discussion:

6
  • 11
    Using true instead of null is nice if you don't want the error window to pop up.
    – justderb
    Commented Aug 20, 2018 at 19:59
  • @justderb: nice! :-D Commented Sep 18, 2018 at 2:29
  • 1
    for me in archlinux/kde 5 plasma I could not do global shortcut without choosing an application first - could not be true|null, but thanks to your suggestion i was able to remapped it to toggle microphone - which on work computer is pointless for me anyway.. thanks!
    – JTC
    Commented Oct 8, 2018 at 11:35
  • Mapping CTRL+q in sxhkd also hijacks the shortcut, preventing Firefox to quit. Commented Mar 8, 2019 at 9:15
  • 1
    Works in Mint 19.
    – Paul
    Commented Jun 6, 2019 at 1:25
9

Disable Ctrl+q with userChrome.js in Firefox Quantum

This can be accomplished without an external application by a tiny bit of javascript in your Firefox profile.

As a prerequisite, you must enable userChrome.js (see below, or obtain from the original GitHub repo)

After copying the chrome directory and its contents into your user profile, create a file <profile-dir>/chrome/disable_ctrl_q.uc.js with the following content:

var kqa = document.getElementById('key_quitApplication');
if (kqa) kqa.remove();

Lastly, restart Firefox, and ctrl+q will no longer cause the application to exit.


Enabling userChrome.js in Firefox Quantum

For completeness, below are the full contents of the modified chrome files. To enable userChrome javascript, create these two files inside a chrome directory within your Firefox profile.

  1. Type about:support in the address bar.
  2. Under Application Basics > Profile Directory click the Open Directory button to open your Firefox profile directory.
  3. Within the profile directory, make a new directory called chrome
  4. Within the chrome directory, create new files userChrome.css and userChrome.xml with the contents listed below.
  5. Restart Firefox (you probably also want to create the .uc.js file above if you're following these steps to disable ctrl+q)

userChrome.css

/* Copyright (c) 2017 Haggai Nuchi
Available for use under the MIT License:
https://opensource.org/licenses/MIT
*/
@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
toolbarbutton#alltabs-button {
    -moz-binding: url("userChrome.xml#js");
}

userChrome.xml

<?xml version="1.0"?>
<!-- Copyright (c) 2017 Haggai Nuchi
Available for use under the MIT License:
https://opensource.org/licenses/MIT
 -->

<bindings id="generalBindings"
   xmlns="http://www.mozilla.org/xbl"
   xmlns:xul="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
   xmlns:xbl="http://www.mozilla.org/xbl">

  <binding id="js" extends="chrome://global/content/bindings/toolbarbutton.xml#menu">
    <implementation>
        <constructor><![CDATA[
            function makeRelativePathURI(name) {
              let absolutePath = Components.stack.filename;
              return absolutePath.substring(0, absolutePath.lastIndexOf("/") + 1) + name;
            }
            // The following code executes in the browser context,
            // i.e. chrome://browser/content/browser.xul
            Services.scriptloader.loadSubScript(makeRelativePathURI("userChrome.js"), window);
        ]]></constructor>
    </implementation>
  </binding>
</bindings>
5
  • 2
    This doesn't work in Firefox 62
    – Grief
    Commented Aug 16, 2018 at 10:54
  • 1
    It works with the latest stable, Firefox 61. Hopefully 62 is fixed before it leaves beta. Commented Aug 16, 2018 at 16:40
  • I now use the solution from CrazyPyro superuser.com/a/1352295/308508 Commented Feb 8, 2019 at 20:36
  • 1
    Doesn't work in 69.0.2 (not beta). Also, document.getElementById('key_quitApplication') returns null. Has the name of this element changed?
    – tsbertalan
    Commented Oct 18, 2019 at 17:22
  • @tsbertalan After updating from 66 to 84, that setting in my userChrome.js also didn't work anymore. However, after trying to find whether the name changed and finding that it didn't change, I finally found the reason: userChrome.js is not loaded anymore. I installed this patch to allow JS injection and put those lines of code into /chrome/custom-shortcuts.uc.js (any chrome/*.uc.js is loaded) and it works again!
    – mxmlnkn
    Commented Dec 5, 2020 at 9:26
9

An ugly, but simple and effective workaround is always keeping a page open that has an active onbeforeunload handler, i.e. will trigger the "This page is asking you to confirm that you want to leave - data you have entered may not be saved." dialog when you attempt to close it.

That way, if you accidentally try to CTRL+Q, you will receive that dialog, and can choose "stay on this page" to cancel the exit.

Edit: Custom page I made just for this purpose

Edit: as of 2020-05-10 / Firefox 76 (and likely quite some time before that), the built-in warning dialog works for me with these settings:

restore previous session checked, warn you when quitting the browser checked

Since the bug is still untouched, I have no idea if this is actually fixed or if it just happened to start working due to some list randomly being in the right order or something. If you're still experiencing this issue after the date of this edit, would you mind leaving a comment confirming that the settings are set the same way, the Firefox version you're using, and the OS?

3
  • nice hacker spirit there! Commented Jan 15, 2019 at 15:55
  • Thanks! Added a link to my implementation. Commented Apr 22, 2019 at 21:44
  • Thanks for this. Works for me, and so cheezy I love it (: It's astounding to me that FF has messed up this simple thing.
    – jwd
    Commented Oct 31, 2019 at 22:06
7

I was able get what I need with AutoKey. After installation I created empty script with assigned Ctrl+Q as "Hotkey" and .*Firefox as "Window filter".

enter image description here

Then in AutoKey preferences I added it to autostart and disabled notification icon, so it becomes transparent for me.

enter image description here

I used it for a few hours and it looks promising - no false-positives or missed catches so far. Right now Ctrl+Q does not working for Firefox, but it works perfectly fine in PhpStorm for example.


In addition bug 1215061 gives some hope that this will be easier in future and Firefox will finally get some decent keyboard shortcuts settings.

1

I have been plagued by this on and off through varoius firefox versions, too.

Here is one solution that always works, and works for other browsers too:

Keep a tab open with this page (you can save it locally): https://janschejbal.github.io/disable-ctrl-q/

You have to click the button on that page once so firefox thinks something important is going on there, but then you can completely forget about it.

Read the page for an explanation.

It has saved me a good handful of times (:

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .