0

I have a problem with google (search) results language. I was in Holland couple of weeks ago, and while I was there google forced on me to go through new ad rules. And they offered those rules in Dutch language, naturally :) !?!

I turned every option to Off, and I want it to stay that way - I do not need anyone to give me ads that are personalized - since mostly I buy what I search for on same day.

Now I am back to my country, and google still displays result in Dutch. When I open google.com, at the bottom status bar it says Netherlands. I am not redirected to google.nl, its .com. When I click Advertisement, it displays page in Dutch language. When I click on Business, About, Privacy, Terms or Settings, all is in English. In Settings there is nothing set that points to Netherlands.

When I open some google search, in status bar its says:

Location: Hertogenbosch - Reported by this computer. If I click on update location, it shows popup asking to allow location access, I allow it, but it does not change it?

Next to update location there is a Learn More option, where you can see that google updates location based on IP, location history (it was off) and recent locations. My current IP has nothing to do with Netherlands, I have also tried to add manually location, but google still says Netherlands and Hertogenbosch in status bar.

Any advice how to remove Netherlands and Dutch language from my google search and offers? Browser I am running is Firefox latest version, OS is Windows 10 Pro English.

  • If it's not important to you, try deleting your browsing history and the cookies in Firefox. – DrZoo Apr 30 '18 at 20:54
  • Just tried it, after deleting everything, and went on google.com, i again receive privacy reminder from google, and results in dutch. – Goran May 1 '18 at 12:29
  • You could try this or give one of these localization answers a shot. – DrZoo May 1 '18 at 14:33
  • Have you tried incognito mode to see if it changes the behavior? – DrZoo May 1 '18 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.