1

tl;dr Is there anything that I can do to "clean" network "path" to my printer or otherwise force my Windows 7 to recognize my printer as being on-line (which is true), while it claims that is off-line?


I have Windows 7 Home Premium SP1 (with all recent WU updates installed) and HP LaserJet Pro MFP M426fdn. And for past few days I have a terrible problems with printing.

Actually I am able to print something only upon system start / restart (from "old" printer spool), as immediately after full system startup / "old" spool cleanup my Windows 7 starts claiming that my printer is offline.

Performed checks:

  • printer itself (has LED screen) claims that it is connected to my network and to the Internet,
  • ping 192.168.1.2 has 100% response with average response time at <1 ms,
  • other computer (with Windows 10), connected to the very same network and printing on the very same printer has absolutely no problems with that and prints everything right away.

The situation came to the (curiosum?) point that I can print my documents via HP Connected (I'm sending them over email and printer "captures" them and prints them; unfortunately I can't select only certain pages or print both sides this way), but I can't print it directly over network.

Or to the point where after system restart printer prints documents (from "old" spool) and minute or two later it is unable to print another document:

enter image description here

Is there anything that I can do (except restarting my Windows after each document is sent to print)? Is there any way I can "clean" network "path" to printer or force my Windows to understand that printer is in fact on-line?

I'm must admit that having printer with 100% ping responses that, Windows claims, is turned off, actually limits my knowledge and resolution ideas to minimum.

enter image description here enter image description here enter image description here

2
  • 2
    Have you tried completely removing and reinstalling the printer also? May 1 '18 at 10:58
  • @djsmiley2k As in my comment to Tim_Stewart's answer. This printer was operating normally on the very same network and using (sending documents) from the very same PC for about past two months. Thus I expect recent changes to my network configuration to be suspect of my issue. I need to try to track then down before I apply such obvious solution like reinstalling the printer. Since nothing changed in PC, driver and printer configuration and only network configuration seems to be the issue, I expect that reinstalling the driver won't solve this problem. But, thanks for the idea.
    – trejder
    May 6 '18 at 8:00
2

When this happens, its usually enough to restart the print spooler services.

You can do this by going to services.msc and finding the Print Spooler service, then use the button to restart it.

Alternatively, a command prompt as admin with the following 2 commands will work just fine too:

net stop spooler
net start spooler

If the spooler has been restarted and the printer is online, but the documents in the queue refuse to print, you need to forcefully remove them.

First stop the print spooler services, then open the following folder:

C:\Windows\System32\Spool\PRINTERS

Remove all files from this folder

Now start the print spooler, and all should be working again.

If for whatever reason this doesn't solve it, turn off the printer itself, wait 5 seconds, and turn it back on, then repeat the above if still necessary.

3
  • I think this may highlight the problem which I've seen during my time on various service desks - you may find there is a number of old items in the spooler folder which don't show up as 'in process' jobs - these get stuck, and the spooler never continues. Once you removed whatever's stuck you might find the problem never returns. May 1 '18 at 10:50
  • @djsmiley2k yup, that's possible. Not always the case, but its possible.
    – LPChip
    May 1 '18 at 10:55
  • @LPChip Your solution solves the issue only partially and only from time to time. Sometimes restarting Print Spooler does all the job (i.e. "hanging" document prints immediately) and sometimes in only "wakes" up the printer but print queue for that printer still claims that printer is off-line. In that later cases also stopping service, removing files and starting the service again does not solve the problem. As does not solve it shutting down both printer and service and restarting them back after approx. 2-3 minutes. Nothing. Only full computer restart does solve this problem. Weird.
    – trejder
    May 6 '18 at 8:19
0

Apparently Windows doesn’t like it if you setup your printer by connecting to the printer and installing the driver whilst browsing your network…. (I don’t know why). Anyway the solution is to add the printer as a local printer, it also seems to stop it from being goofy with some of the print-spooler issues. (I can confirm this works for WIN-7 x32 & x64. but haven't tried it on 8.1 or windows 10 yet.

Make sure your printer is using a static/manual IP address outside of the routers DHCP pool.

  1. Load up your printer browser in the control panel.
  2. I recommend deleting all your network printers and restarting your PC, it seems that windows holds on to some information until you restart.
  3. Go back to the printer browser in control panel
  4. Click “Add a Printer”.
  5. Now select add local printer.
  6. Create new port. (choose TCP/IP)
  7. When it asks for Enter a port name use the IP Address of the printer. (give it a sec, it should detect the port to use.)
  8. Follow the steps to install the printer driver again, if you have installed the printer before, windows should still retain that printer driver you used.
  9. Now repeat for any of the other network printers you have.
3
  • Thank you. I'll check your solution ASAP and report here, as LPChip's solution did not solve my issue. The only problem is that this just started happening after recent changes to my network. Because previously, after printer was installed, I was able to operate on it without any problems (no Windows or printer driver reinstall needed) for about two months. So, I still need to re-verify my network configuration prior to introducing suggested changes (i.e. installing printer as local one).
    – trejder
    May 6 '18 at 7:52
  • 1
    If your network configuration changed, then the chances are high that either your printer is on DHCP and its IP address changes, or it has a fixed IP address, but its still in the scope of the DHCP and gets a disconnect because another device gets the same IP address.
    – LPChip
    May 6 '18 at 10:46
  • 1
    @LPchip, good advice. Totally forgot to mention a static IP for the printer. I'll add it. May 6 '18 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.