4

I find today that I can no longer mount my Netgear ReadyNas drive because apparently it is using SMB1 and Windows 10 have disabled since release 1709. This is very problemaic because I need to access these files and because I have lost the admin password for the ReadyNas itself so I cannot login in order to update/reconfigure it to use SMB2 instead.

Microsoft refers me to https://support.microsoft.com/en-us/help/4034314/smbv1-is-not-installed-by-default-in-windows which in turn refers me to https://support.microsoft.com/en-us/help/2696547/how-to-detect-enable-and-disable-smbv1-smbv2-and-smbv3-in-windows-and if I really want re-enable SMB1

And I successfully did re-enable SMB1 by running

Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol

from Powershell as Adminstrator.

However even after reboot I still cannot re-establish connection to my Netgear from Windows Explorer, it gives the same error

What else do I need to do ?

PS C:\WINDOWS\system32> Get-WindowsOptionalFeature –Online –FeatureName SMB1Protocol


FeatureName      : SMB1Protocol
DisplayName      : SMB 1.0/CIFS File Sharing Support
Description      : Support for the SMB 1.0/CIFS file sharing protocol and the Computer Browser protocol.
RestartRequired  : Possible
State            : Enabled
CustomProperties :
                   ServerComponent\Description : Support for the SMB 1.0/CIFS file sharing protocol and the Computer
                   Browser protocol.
                   ServerComponent\DisplayName : SMB 1.0/CIFS File Sharing Support
                   ServerComponent\Id : 487
                   ServerComponent\Type : Feature
                   ServerComponent\UniqueName : FS-SMB1
                   ServerComponent\Deploys\Update\Name : SMB1Protocol

Solution

Thanks Bob, SMB 1.0/CIFS File Sharing Support was enabled but within it SMB 1.0 Client was not enabled, checking that box and rebooting fixed the issue.

8
  • 3
    Can you go to Programs and Features (old Control Panel) => Turn Windows Features on or off (left sidebar) and check if SMB 1.0/CIFS File Sharing Support is enabled (checked) in that list? i.stack.imgur.com/vpUS1.png from the second MS Support link. – Bob May 1 '18 at 14:49
  • 1
    Also see what Get-WindowsOptionalFeature –Online –FeatureName SMB1Protocol says. – Bob May 1 '18 at 14:50
  • simple solution, get older Win10 version (1607) ISO, use Rufus to create a WinToGo on an USB connected HDD, boot that WinToGo and access the NAS here over SMB1 and get all data – magicandre1981 May 1 '18 at 15:39
  • Thnakyou @Bob that was basically the issue , see my updated question with solution. – Paul Taylor May 1 '18 at 16:30
  • @PaulTaylor Please add that as a self-answer below rather than editing it into the question. – Bob May 2 '18 at 0:51
5

The problem was that although I had sucessfully reinstalled SMB1, the SMB1 client had not been enabled, so if you hit this problem there are two stages.

First Reinstall SMB1.0

  • In Task bar search for Windows Powershell then Run as Administrator
  • Run Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol
  • Reboot

Now re-enable Client Support

  • In Taskbar search for Control Panel and start it
  • Select Program and Features
  • Select Turn Windows Features On and Off on the top left handside
  • Find SMB 1.0/CIFS File Sharing Support in list
  • Click on the + button to expand
  • Ensure all three SMB options are enabled
  • Click OK
  • Reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.