1

My Windows 10 PC is unable to access a shared folder of my NAS.

The NAS does not appear under Network and when I try to enter the address \\mynas or \\<ip> I just have an error message "Windows cannot access \\mynas".

The NAS is correctly listed and I can browse the folders from an Android phone using several apps like Ghost commander or ES File manager.

I tried disabling the firewalls on the Windows 10 PC, it does not change anything. I have checked all the "network share" settings and everything seems ok.

So I did a packet capture using wireshark. And what happens is that everything goes well, at the start. Windows retrieve the NAS ip address from its netbios name and start the protocol negotiation. But as soon as Windows received the "Negotiate Protocol Response" from the NAS, it closes the TCP connection. Windows then does a 2nd try, but the same thing happens.

Here is the "Negotiate Protocol Request" sent by Windows: enter image description here

Here is the "Negotiate Protocol Response" sent by the NAS: enter image description here

The next packet is a TCP RST,ACK from Windows

7

This error indicates it requires the SMBV1.0. If you use Windows 10 1709, by default SMBv1.0 is disabled. Reinstall it to access the NAS with PowerShell command:

Enable-WindowsOptionalFeature -FeatureName SMB1Protocol -Online

| improve this answer | |
  • Would it be better if the NAS settings be updated to support SMB2 or higher? (assuming it is possible to update the NAS setting) – Darius May 2 '18 at 7:37
  • 1
    Enabling SMB 1 did the trick. No need to run the PowerShell command. – Benjamin T May 2 '18 at 7:48
  • @Darius It would be better. But the NAS in question is just a feature of a modem/router provided by my ISP. There is no option to control the SMB protocol version and I doubt they will update this feature. – Benjamin T May 2 '18 at 7:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.