1

I have been using the bridged adapter to connect a Linux Mint virtual machine to the physical network without issues. Recently I installed the OpenVPN server on my machine, and ever since the bridged adapter does not seem to work.

The guest doesn't even recognize that there's a network, it's stuck in "Connecting" mode. It seems like all other adapter types work fine, except for the bridged adapter. I haven't made any changes to the network settings manually.

What could be causing this?

2

Installing the OpenVPN client or server also installs the Windows TAP network adapter. (The name on the first line is most likely different, but the bottom line should match.)

What's most likely happening is that VMware's default option of "Automatic" for selecting the card to bridge to causes the VM's traffic to go through the TAP adapter. This is an issue because you likely don't have network connectivity there, and even if you do, it's not to the network you'd expect.

You can tell VMware exactly which adapter(s) to bridge to like this:

  1. Open Edit > Virtual Network Editor...
  2. Click the Change settings button in the bottom right
  3. Select VMnet0 (if it's not selected already)

    • If you only use one adapter (e.g. no separate Wi-Fi/wired) you can just select it from the "Bridge to:" dropdown.
    • Otherwise click "Automatic Settings..." (next to the dropdown)
      • A window will open where you can un-check any network adapters you want to exclude from the automatic adapter selection.
  • This is also the solution when installing the SonicWALL Global VPN Client -- ie, uncheck the box for SonicWALL Virtual NIC in the list of adapters – Jeff Feb 26 at 22:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.